"Input string was not in a correct format" with Perforce

Using Perforce, I'm trying to link an existing Perforce depot with a pre-existing database. I'm getting the same error from this thread:
http://www.red-gate.com/messageboard/vi ... hp?t=11607

I'm looking at the suggestions from that thread and I saw this:
"I think this is issue SOC-1369, which occurs if you link a non empty db to an existing repo and the SQL contains curly braces {}. We are looking into a fix for this. "

Getting rid of the curly braces worked for the person, but I have no idea where the curly braces are or what the root cause is. Plus, I'm using Perforce instead of SVN.

Does anyone have any suggestions on what I should be doing or where I should be looking?

Thanks for any help in advance.


  • James BJames B Posts: 1,124 Silver 4
    For other users coming across this post, the problem has been tracked down to a hex value being assigned to a parameter in a stored procedure. As SQL Server seems to accept this as valid syntax, it's possibly a bug, so we'll check over it.
    Systems Software Engineer

    Redgate Software

Sign In or Register to comment.