What are the challenges you face when working across database platforms? Take the survey
Options

[650] You can only specify the READPAST lock in the READ COM

kendoskendos Posts: 5
edited October 17, 2011 2:13PM in SQL Compare Previous Versions
[650] You can only specify the READPAST lock in the READ COMMITTED or REPEATABLE READ isolation levels.

Get this error when trying to update a database hosted on a server that has replication enabled for that server.

Using SQL Compare 7 if that makes a difference...

Thanks for any guidance.

Ken.

Comments

  • Options
    Thanks for contacting Red Gate.

    I'm fairly sure that v7 has this option, but if you click the options tab when you create a new project, you can check the box for 'do not use transactions in synchronisation scripts'. This should stop you getting that error, however, something to bear in mind is that it wont roll back if the script fails so you need to make sure you're happy with it before you synchronise.

    I hope this answers your question, if you're unsure whether or not you are eligible for more recent versions of the tool, give is a call and speak to the sales team, or you can email sales@red-gate.com.

    I hope this helps.

    Thanks.

    Siân Williams
    Red Gate Software
    Tel: 0800 169 7433
    sian.williams@red-gate.com
  • Options
    Or... you can set the transaction isolation level in the application if you use SQL Compare 9.5. See

    http://www.red-gate.com/MessageBoard/vi ... 1312#51312

    for more details.

    David Atkinson
    Product Manager
    Red Gate Software
    David Atkinson
    Product Manager
    Redgate Software
Sign In or Register to comment.