SQL Search only searches modified objects

SonOfGreySonOfGrey Posts: 4
edited July 2, 2013 2:19PM in SQL Search Previous Versions
Hi all,

I'm a big fan of SQL Search, but it's lettingme down lately.

I have a strange problem: it seems that SQL Search can only search in objects that are modified since a certain day or something.

If I do a search now, it gives all kinds of results, but for example it misses a lot of objects like procedures. If I then go to a missing procedure and execute an ALTER on it (even when not really changing anything), then the contents of that procedure can be found again by SQL Search.

Does this sound familiar?

Microsoft SQL Server Management Studio 10.50.1600.1
Microsoft Analysis Services Client Tools 10.50.1600.1
Microsoft Data Access Components (MDAC) 6.1.7600.16385
Microsoft MSXML 3.0 4.0 5.0 6.0
Microsoft Internet Explorer 8.0.7600.16385
Microsoft .NET Framework 2.0.50727.4959
Operating System 6.1.7600

SQL Search (but I've tried different ones)

Thanks for your help!


  • Anu DAnu D Posts: 876 Silver 3
    Many thanks for your post and apologies for inconvenience caused.

    Looks like some issue with the cache. Have you tried 'Force reindex'?

    If you still see this issue can you also try manually deleting the index files and then try replicating the issue after that?

    You can find the index files here: %USERPROFILE%\AppData\Local\Red Gate\SQLSearch 1\Indexes

    Let me know how it goes.
    Anuradha Deshpande
    Product Support
    Redgate Software Ltd.
    E-mail: [email protected]
  • Many thanks for that suggestion. I wasn't aware of the fact that there were index files that I could delete!

    I tried refreshing and force reindexing many times, but it didn't helpt. Also reinstalling etc.

    I really hope that removing the index files helps. I will try this first thing tomorrow and I'll let you know how it works out.
  • So far removing the index files fixed the problems!

    Of course I don't know what caused it, and I hope it was just a one time incident.

    Thanks for offering a solution!
    Kind regards
  • Anu DAnu D Posts: 876 Silver 3
    No problem!

    I am glad that your issue is resolved :)
    Anuradha Deshpande
    Product Support
    Redgate Software Ltd.
    E-mail: [email protected]
  • First, thank you for your answers.
    I also had the same problem recently, and your answer fixed my problem.

    However, I now have a very serious nagging doubt about all the searches that I have done in the past using SQL Search: What if I missed the update of a field in an SP because the search didn't show it?

    Does anyone know if Redgate is looking at fixing this problem in a future release?
    Thank you.
  • I just ran into this issue too, where some stored procedures were missing from the results and refresh/force reindex did not fix the problem. Deleting the cache files worked for me as well.

    I also have the same concerns as delbaz. I've grown a little bit dependent on SQL Search for tracking down references and dependencies, so incomplete results are a big problem.
Sign In or Register to comment.