SQL Monitor Remote File Access?

dennisrochedennisroche Posts: 3
edited May 12, 2011 12:09PM in SQL Monitor Previous Versions

I'm setting up SQL Monitor to collect data from a Windows 2k3 Server (\\SERVER). Our IT department has refused to give us local administrator permissions to the server, so we have created a new user (DOMAIN\MonitorUser) account.

I have followed the steps listed in the Testing data collection methods article to almost get up and running. I have been able to setup PerfMon, Remote Registry, and WMI remote access and launch permissions only to be stuck with providing remote file access. I'm unable to change/add permissions for the DOMAIN\MonitorUser to access IPC share (C$).

Q: This there a way to specify what share the SQL Monitor uses? I can create another share on the C:\ drive without any problem, however I can see from the log files that it specifically wants the \\SERVER\C$\ share.


:!: I need to resolve this final issue before I can request to our studio to purchase SQL Monitor.


  • Options

    Thanks for your message.

    Unfortunately, SQL Monitor doesn't support specifying the share which SQL Monitor uses. I have raised an enhancement request for this (SRP-4160).

    But having said that, you can still start monitoring your machine and SQL Server. If remote file share doesn't work then "SQL Server error log entry" and "Deadlock" alerts won't get raised. Also, you would consistently see error message on Monitored Server page complaining about remote file share. But other than these two things, everything else should work as expected.

    Priya Sinha
    Project Manager
    Red Gate Software
  • Options

    Thanks for your reply.

    We have managed to resolve the data collection issues that we had by changing the user credentials that we were using to monitor the host machine. I have to say it was quite a process to try to set the correct permissions for someone that was not in the administrator group, e.g., Remote Registry, WMI, IPC Share,...
Sign In or Register to comment.