diagram won't update from schema

thirster42thirster42 Posts: 34
edited May 11, 2011 5:27AM in SQL Dependency Tracker
i've got a diagram that i've set up. i want it to update because i've made some changes, but now when i go to update from schema it's throwing an error stating "no tables were found for foreign key FK_DIR_Investigation'.

i know exactly where that foreign key is, and as far as i can tell it shouldn't be looking at that relationship. i've tried adding both tables in the relationship but ti still throws the error. is there a way to tell exactly why it's throwing this?


  • Hi there,

    Thanks for your post. Unfortunately, there isn't any logging within SQL Dependency Tracker which would enable us to ascertain easily exactly what is happening.

    Without having your DB to repo in house what's happening, I suspect even though the object isn't necessarily added to the project, the dependency is still being taken into account as dependencies for the entire DB are taken into account, not just the objects selected.

    Have you tried recreating the project from scratch at all?

    Peter Peart
    Red Gate Software Ltd
    +44 (0)870 160 0037 ext. 8569
    1 866 RED GATE ext. 8569
Sign In or Register to comment.