What are the challenges you face when working across database platforms? Take the survey

Email Notification

jortizvjortizv Posts: 5
edited May 6, 2011 2:13PM in SQL Backup Previous Versions
Hi I have the following problem, the log files are massive as my database is very big with thousands of databases, so when an error happens it just send this 50MB file over an email which as you would have guess it is impossible to transfer due to limitations is most email providers to 20MB or so.
In other backup applications I could disable attach error log and just send the email saying there was a failure.
is there anything I can do to stop it from sending me this large email???

any help would be appreciated.



  • Options
    peteypetey Posts: 2,358 New member
    Could you please try a patched SQL Backup Agent service (version I've added a MAILTO_NOLOG option, so that SQL Backup does not send the contents of the log in the e-mail e.g.
    EXEC master..sqlbackup '-sql "BACKUP DATABASES AdventureWorks TO DISK = [<AUTO>] WITH MAILTO = [dba@yohz.com], MAILTO_NOLOG"'
    You can download it from here:

    ftp://support.red-gate.com/Patches/sql_ ... 0_1031.zip

    That archive contains the SQL Backup Agent executable file (SQBCoreService.exe). To replace the existing service executable file, do the following:

    - ensure that no SQL Backup processes are running
    - stop the SQL Backup Agent service, or disable the cluster resource if on a cluster
    - rename the existing executable file (SQBCoreService.exe) in the SQL Backup installation folder
    - extract and place the patched executable file into the same folder
    - restart the SQL Backup Agent service/cluster resource

    Let me know if this works for you.

    Please note that this is an unofficial workaround for now. It might or might not make it into the next official release.
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
  • Options
    oh nice.. thank you...
Sign In or Register to comment.