What are the challenges you face when working across database platforms? Take the survey
Options

INSERT INTO becomes INSERT INTO

hfxDBAhfxDBA Posts: 3
edited April 20, 2011 7:33AM in SQL Prompt Previous Versions
if typing INSERT INTO (1 space between words) or using the built in snippet "ii" there is only 1 space between the key words. if you then choose to format code (ctrl+K, ctrl+Y), an additional space shows up between the key words.

Am I just being oblivious to the option to only have 1 space here, or is this a "feature"?

Comments

  • Options
    Anu DAnu D Posts: 876 Silver 3
    Many thanks for your post.

    Can you try selecting this option?

    SQL Prompt 5 --> Options --> Format --> Data Statements --> New lines --> Indent subclauses (select this option)

    Does this makes any difference?
    Anuradha Deshpande
    Product Support
    Redgate Software Ltd.
    E-mail: support@red-gate.com
  • Options
    selecting this option does remedy this issue, but I do not want sub-clauses indented. As far as my testing has gone, I do not see any other combination of keywords that have 2 spaces between them instead of just 1.

    If this is by design, I am not sure of the purpose. It looks out of place when compared to other lines of formatted code using this tool.
Sign In or Register to comment.