SQL Packager and XP Run As "Security" / Activation problem

Jamie ClaytonJamie Clayton Posts: 19
edited November 2, 2005 11:09AM in SQL Packager Previous Versions
G'day,

I've installed all my Redgate SQL Bundle (developer edition) tools on my XP development laptop, under and a local administrator user and ran all the online activation codes.

As part of our development environment, I've then logged off as local administrator and then used my "normal" xp user profile to login. I then run the various Reggate software tools succesfully, except SQL Packager.

When I try to run that application, either as local non administrator user or "Run As: Administrator" in windows XP, I get an Activation error which causes and .net security exception (non adminstrator user) or "Access to path "C:\Docu~\Admin~\Locals~\Temp\****.cs is denied" error (Local Administrator).

I suspect I've installed the application incorrectly or need to activiate in "Local Admin" again. Alternatively, is there a security requirement for the SQL Packager that requires local adminstration rights?

Would anyone advise the best course of action.
Jamie Clayton
Senior Software Developer
Jenasys Design Pty Ltd, Australia

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello Jamie,

    SQL Packager uses a 'skeleton' C# project in the c:\program files\red gate sql bundle\sql packager code templates folder. When you use SQL Packager to create a package, it modifies these files and saves them to a location indicated by the %TMP% environment variable, where the project will be built and an executable package produced.

    It may be easier to figure out why this had happened if you can tell us, first of all, when does this happen (I'm assuming when you create a package), and how you are using the RunAs command. Do you simply right-click the Packager icon and select RunAs, or do you use the command prompt version. If that's the case, maybe it would help to use the /env and /profile switches to make sure you're saving the temp files to the right place.

    Please let me know what you find out.
  • Brian,

    Ok well the problem was occuring when I tried to use the Right Click "Run As" option off a SQL Packager Icon/Shortcut. It wouldn't allow me to run the application at all.

    I have worked out what was going wrong however and it was nothing to do with your software. The problem was the "Administrator" account didn't have full permission to its "My Documents" folder and hence caused an access denied when trying to write to the %tmp% environment variable.

    After I've adjusted the security on that folder the activation problem went away.
    Jamie Clayton
    Senior Software Developer
    Jenasys Design Pty Ltd, Australia
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi Jamie,

    That certainly sounds feasable. Thanks for getting back to us with the solution.
This discussion has been closed.