SQL Prompt 5 trail uninstalled but lost SSMS intellisense

kr77025kr77025 Posts: 2
edited June 3, 2011 4:48AM in SQL Prompt Previous Versions
I downloaded the free trial of SQL Prompt 5, but then uninstalled software when trial ended. I still see a SQL Prompt 5 menu option in SSMS and now intellisense doesn't work in SSMS.

Any help would be appreciated.

Comments

  • Many thanks for your post and apologies for inconvenience caused.

    Following are my suggestions to your issues:

    SQL Prompt 5 menu option in SSMS -

    After SQL Prompt have been uninstalled, their menu items may still be left in SQL Server Management Studio and/or Visual Studio. When this happens, it will be necessary to remove these manually.

    From the Visual Studio main window, click on tools, customize. Leaving this window open, click and drag sql prompt down the page onto an empty space in the left window. This should remove it from the menu bar.

    The procedure for removing the menu items from Management Studio is identical to the above.

    Intellisense doesn't work in SSMS -

    Can you kindly check if SQL Server 2008 intellisense is switched on?

    You can turn on SQL Server 2008 intellisense using the following settings:

    Open Tools>Options>Text Editor>Transact-SQL>Intellisense. Is Intellisense enabled here?

    Also if you click General under the Transact-SQL list is Auto list members and Parameter information selected?

    Kindly restart management studio after saving this settings and recheck it and try reproducing the issue?

    Kindly let me know if the above suggestions fixes the issue for you.
    Anuradha Deshpande
    Product Support
    Redgate Software Ltd.
    E-mail: [email protected]
  • I followed the steps, and my intellisense is still not working.
  • Can you verify whether you're connected to a SQL Server 2008 instance or a SQL Server 2005 instance?
    David Atkinson
    Product Manager
    Redgate Software
  • Hi,

    I had a similar problem.

    If you are using SQL2008-R2 you need to install the cumulative update 7. After that my intellisense worked again.

    There was an issue with the Visual Studio 2010 hotfix or SP1...
    Regards,

    Thorsten
Sign In or Register to comment.