Competition: What’s your favorite Redgate tool? Enter now.

Error using cmdline with Data Compare

ryanmorrisroeryanmorrisroe Posts: 12 Bronze 1
I'm having an issue with the command line interface of DataCompare. My target db has a table that my source db does not (I only care about one table within the two databases). If I run my project from the DataCompare GUI everything works fine (a line shows up saying "1 Table or View could not be compared" but otherwise nothing is out of the ordinary), but when I run it from the command line I get:
Registering databases
Mapping
Comparing databases
Error: Object reference not set to an instance of an object.

If I physically remove the extra table from the target this error does not occur through the command line. I've been unable to find a way to remove the extra table from appearing in the "Tables and Views" section in the GUI (it shows up in the target db with blank fields for the source db, it also appears in the unmapped section on the mapping tab) - I feel like this is causing the error to be thrown. So far no combination of /Include or /Exclude switches has solved this problem.

Comments

Sign In or Register to comment.