What are the challenges you face when working across database platforms? Take the survey
Options

Data Compare will halt while synchronizing data

JonBoyJonBoy Posts: 10
Data Compare stops while synchronizing data. Easily reproducible 100% of the time.

Start a data compare between 2 databases with tables that have differences. Wait for Data Compare to generate the sql scripts. Synchronize tables through DataCompare. When the Synchronize popup is displayed (window with the % competed in the title bar), attempt to drag the window to move it.
Data compare will then stop. A popup will be displayed stating that the text could not be applied to the DB (text will be different each time because it looks like the actual raw text it's at while updating the data from the scripts). A new window will be displayed stating "Tasks cannot be completed".

The fix would be to allow the user to move the window without cancelling the data synch.

Comments

  • Options
    James BJames B Posts: 1,124 Silver 4
    Thanks for your post.
    We've just tried replicating this on a couple of PC's, but so far we can't. We can happily wiggle the box around during the sync without it causing any problem, the process continues and completes successfully.

    What operating system are you using? And are your graphics card drivers up to date?
    Systems Software Engineer

    Redgate Software

  • Options
    Using WinXP x64. Everything is updated. I can verify consistently if you want to do a remote session.
  • Options
    Just in case it's operating system specific, I've tried it on a couple of XP machines here (both x86 and x64) but I still can't get it to happen. A couple more colleagues tried it, and still no problem.

    Can I double-check the exact version you're on?
    Also, you may want to check to see if there's a logfile (right click the main SQL Data Compare titlebar and pick the option to locate log files).

    Thanks for the offer of a remote session - not sure how useful it is at this point, as I'm unsure as to what may be causing it. It's certainly not a problem I've heard of previously.

    One other thing - do you have other users there who can get the same to happen? Or does it work ok for some of them?
    Systems Software Engineer

    Redgate Software

  • Options
    I first noticed this bug on version 8.1.0.4. Downloaded and updated to 9.0.0.117 yesterday. Enabled verbose logging. Did a couple tests and examined the log afterwards, but nothing was written to it of note. I'll do a couple more tests in the morning. The issue will also occur if a large data sync is occuring, I'm working on another app and put focus back on redgate to see what the status is; it will 50% of the time stop this way (vs dragging the window which stops 100% of the time).

    Had another co-worker test this issue on his box (WinXP x86, DataCompare version 8.1.0.4). Same thing. As soon as the data sync occurs, he dragged the window and the sync stopped with the error reported above.

    All of our dev systems are running dual monitors. Have no idea if that's what's causing this issue, just throwing it out there.

    Sucks when it stops with a large data sync since it has to be restarted.
  • Options
    James BJames B Posts: 1,124 Silver 4
    I don't think dual monitors will be the cause, as all the machines here we've tested on are running that configuration.

    I guess it could be more likely on large syncs- I've only tested on scripts that take around 10 secs or so to execute. What kind of size are you talking about?
    Systems Software Engineer

    Redgate Software

  • Options
    I've been doing data syncs on various tables where the different row counts are > 1 million rows.

    For testing purposes, I did a couple smaller tables where the estimated remaining time is < 1 minute and the issue still occurs by moving the status window.
    Log doesn't log anything with the sync is halted (in verbose mode).

    08:35:59.301|Info   |SQL Compare Engine  |1  |Start SaveToDisk: C:\Documents and Settings\JC\Local Settings\Temp\Red Gate\SC_Clone_67c5802f-1eba-4f12-b847-7daf9b16500d.tmp
    08:35:59.332|Info   |SQL Compare Engine  |1  |Finish SaveToDisk: C:\Documents and Settings\JC\Local Settings\Temp\Red Gate\SC_Clone_67c5802f-1eba-4f12-b847-7daf9b16500d.tmp
    08:35:59.379|Info   |SQL Compare Engine  |1  |Start SaveToDisk: C:\Documents and Settings\JC\Local Settings\Temp\Red Gate\SC_Clone_c1fbf058-56a7-47c7-809d-67eff7ea0d90.tmp
    08:35:59.410|Info   |SQL Compare Engine  |1  |Finish SaveToDisk: C:\Documents and Settings\JC\Local Settings\Temp\Red Gate\SC_Clone_c1fbf058-56a7-47c7-809d-67eff7ea0d90.tmp
    
  • Options
    No love on this issue? :shock:
  • Options
    Do you still have this as an open issue?
  • Options
    James BJames B Posts: 1,124 Silver 4
    Apologies, it seems I didn't get the email to say you'd replied. I'll try a larger dataset to see if that makes any difference, but if not, then I'm not sure what we can do as so far none of us here have been able to replicate the problem and I don't see any other customer having logged it previously either.
    Systems Software Engineer

    Redgate Software

  • Options
    So, I just tried it on a larger dataset (2 million rows) which takes several minutes to sync.
    I wiggled the box around for the whole time and it just ran through without trouble; so I'm not sure why it's behaving like it does for you. Are the machines that you have where the problem occurs all the same hardware? Maybe there's some odd issue around the particular graphics card you have or similar?
    Systems Software Engineer

    Redgate Software

  • Options
    Our boxes are not exactly the same. Mine is a Dell OptiPlex 745. The PC has a Radeon X1550 video card. When a data compare is running, I'm not having any refresh or drawing issues - so I'm not sure how that would cause Data Compare to bomb out?
  • Options
    Hello,

    It seems that I have a similar issue, but I’m not sure it’s related to UI. It has happened to me twice today on a 700k (400MB) table which takes quite some time to sync. First, I got the error when was about 80% done and the error message was something that looked like an invalid piece of SQL. Since the generated SQL script was huge, and I did not have enough time, I concluded that some odd piece of data was not properly escaped, and gave up. I tried few hours later again and got a similar error, but now right at the beginning of the process. I copy-pasted it to Management Studio and it was fine. The only "odd thing" about the snippet was that that was an nvarchar with a newline in it. I clicked on OK, and started the sync again and so far it has been running. It’s 20% done now (which seems very slow), but I’m afraid it may fail again with a similar error message.

    Jan Zich

    Windows Server 2008 R2, SQL Server 2005
  • Options
    OK, so it *did* happen again. This time it happened when I dragged over another window. It may have been a coincidence, but (and this can be a long shot) … could not it be some multithreading issue where the UI thread is accessing some kind of buffer with the SQL because it needs to be repainted and some other thread is using it at the same time to feed the SQL server? As I say, it’s a long shot, but it could explain why it’s seemingly related to UI actions.
Sign In or Register to comment.