Compare process being left running

DaveDustinDaveDustin Wellington, New ZealandPosts: 10 Bronze 4
edited February 23, 2011 4:06PM in SQL Compare Previous Versions
Not sure this is the right forum, because I think it has more to do with the SSMS intergration component than SQLCompare itself.

Details
Windows 7 x64 with SQL Server 2008R2
SQLToolbelt installed including SSMS Intergration Pack

Machine is not domain joined, and SSMS.exe is launched using runas /netonly /user:domain\user to enable using domain credentials for intergrated authentication.

Launching SQL Compare (9 and 8), SQL DataCompare, or any of the Red-Gate tools from the Tools menu in SSMS lauches the applicaiton just fine, still allowing the intergrated authentication to function correctly.

However, when you close the app, the UI goes away, but the process remains running (RedGate.SQLCompare.UI.exe *32).

Even if you close SSMS, the process remains.

If you try and launch SSMS again and then launch SQLCompare again, a second process is created. This one closes properly if you close the app.

Hope this is understandable and is of some use to you. Happy to provide any additional info as required.
Dave Dustin
Data Platform MVP

Comments

  • Thanks for your post.

    We've tried to repro this here but haven't had much luck. Can you tell us if it happens if you try on a second machine?

    Does it happen if you launch SSMS 'normally'?

    Thanks,

    Alice.
    Project Manager
    Red Gate Software.
  • DaveDustinDaveDustin Wellington, New ZealandPosts: 10 Bronze 4
    Hi Alice,

    This is occuring on a newly built box, and previously occured on a different machine.

    Running SSMS normally does not leave the process hanging around.

    I also have SSMSToolsPack 1.9.4.0 installed if that's any help, but no other SQL extensions.

    Cheers

    Dave
    Dave Dustin
    Data Platform MVP
Sign In or Register to comment.