What are the challenges you face when working across database platforms? Take the survey
Options

Insufficient system resources exist to complete the request

deweigenddeweigend Posts: 20
edited September 30, 2005 2:21PM in SQL Backup Previous Versions
I am having a problem with backing up large databases to a network device. SQL Backup with fail with this error: "Insufficient system resources exist to complete the request". I searched through this forum and found several others with the same problem but it looked to me that the only resolution was to remove a /3gb switch from the SQL Server that is being backup up. I also tried to backup locally (as recommended) and it still failed with the same error. Is removing this switch the only resolution? As with one of the posters to this forum, backing up to a local drive and using copyto will not work for us.

Comments

  • Options
    peteypetey Posts: 2,358 New member
    Could you pls provide the following information:
    - what is the backup file size when the error appears?
    - what is the backup drive's sector size? (not cluster size)

    Thanks.
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
  • Options
    This post is to follow-up on this thread and to close it out. What we decided to do was to remove the /3gb from the SQL Server. This SQL Server has 16 gig of RAM and we do have it configured to use AWE. According to Microsoft, servers with more than 16 gig of RAM don't need the /3gb switch and since we had 16 gig we decided that it was OK to go ahead and remove the switch. This action did reduce the over all amount of memory that SQL Server was using and that impacted the buffer cache mostly but the hit ratio did not go down so I think that we are ok. The Network Admins attempted to retrieve the sector size where we are storing the backups but they were unable to get that information with the equipment we are using. With the /3gb switch in place we were seeing any DB over 1 gig in size fail. So far the backups are running fine. We were previously using SQL LiteSpeed to backup our databases and we never had this problem. I would like to see this problem resolved in the next release of SQL Backup because it may not be an option to remove the /3gb switch with the next SQL Server that we deploy SQL Backup to.
Sign In or Register to comment.