Competition: What’s your favorite Redgate tool? Enter now.

SQL Search is indexing your database - Every time I search

a_j_ka_j_k Posts: 3
edited November 20, 2013 9:11PM in SQL Search Previous Versions
Something has changed recently.

Previously SQL Search worked as expected, now whenever I do a search I get the "SQL Search is indexing your database. This will only happen once." message and it takes a very long time (many minutes) for SQL Search to index the database. Once it finishes I'm able to search.

The next time I try to search the same database, I get the same message and it goes through the indexing process again.

I'm running version 1.0.0.321 in Microsoft SQL Server Management Studio version 10.0.4000.0 running on 64-bit Windows 7.

Does anyone have any suggestions about why this would be happening or how to fix it?

Thanks.
Andy.

Comments

  • emoreauemoreau Posts: 55 Bronze 2
    same thing here! any fixes coming soon?
  • Oops that is weird. I can email you both a new build so that you can check if that fixes your issue?

    Thanks and apologies for any inconvenience this has caused.

    Regards,
    Tanya
  • I've crashed four times today (sql search sent the log) - I wonder if this is related. Worst it's been - had just happened once a day or so.

    The funny thing is that I haven't used it all today, so it's gotta be a background task tanking.

    I LOVE sql search but for some reason this latest patch is unstable on my
    system.

    I work with a lot of systems over a VPN that isn't the best in the world. I would really like it to NEVER index them unless I ask it too.

    Even better - an option to simply make indexing manual. I don't use it that often (but boy am I glad I have it when I need it) I would be fine with waiting for an indexing to get done before I search.
  • That is not good... can you confirm the build number of your SQL Search please?
    You can find this by clicking on Help - About.

    Thanks,
    Tanya
    Project Manager
    Red Gate Software Ltd
  • I have not had the test version crash for me, but I've not used it that much. It still indexes the DB every time I access the same database. I uninstalled the old version and installed the new one.
  • I also am experiencing this same issue, constant reindexing.

    Has there been any thought given to changing the design of this tool so that it doesn't build an index at all, but rather just querying the system tables every time?

    Idera SQL Search works this way and it's very fast, no indexing required.
  • This is happening to me with version 1.0.0.340. I'm not even sure how I got this version since it's later than the version on the website (it was installed on my PC at work before I got here). Can you please give an update on this and whether I'm using the correct version?

    BTW I also have a license for RedGate Developer Bundle if that matters.
  • I have a search stored procedure that scans all of syscomments for text like some param. It takes 4 seconds on a slow server with 1400 stored procedures. It would be nice if SQL Search degraded to a brute force scan if no index existed yet.

    If I have a quick search I always use the search sproc instead because I will get results faster, but I really like being able to click on the object and have it highlight in the Object Explorer with SQL Search.
  • I can't tell if the thing is working or not. There's no search button. I just type in what I am looking for and it says it's indexing but it will just index only one time- even though it says that every time I search. Even if the searches are 10 minutes apart.

    Sometimes it works. Sometimes it takes forever. It's faster for me to just search though the stored procs for what I am looking for one by one.

    Someone needs to seriously redesign this thing. It's a POS.
Sign In or Register to comment.