Profiling ASP.Net 4

JimSJimS Posts: 5
Hi,

I am trying to Profile an ASP.NET 4 wcf REST API Service running in IIS7.5 on server 2008 r2.
When I attach and access the service through IE I get ....

HTTP Error 404.17 - Not Found
The requested content appears to be script and will not be served by the static file handler.

Is there something I am missing, I can't see any other config options in the profiler.

When I stop the profiler all starts to work.

Any help much appreciated.

thanks
Jim

Comments

  • Brian DonahueBrian Donahue New member Posts: 6,590 New member
    Sorry, Jim, we do not have an answer for this. The IIS installation has apparently dropped the ISAPI filter that causes IIS to compile and run ASPX pages rather than serving them as static (HTML) files. It's the same error message you would get if the .NET Framework got uninstalled or the ASP .NET feature got removed on a server 2008 system.

    ANTS Profiler does configure IIS when attaching. If you are actually launching rather than attaching, there is a possibility that the configuration is not being created correctly. When profiling normally (not attaching), Profiler has to create a cut-down applicationHost.config and start w3wp.exe using that config file.

    In either case, we have had no reports of this message before. We may have to continue this discussion over email so we can troubleshoot it properly.
  • That would be helpful. Please email me.
  • Brian DonahueBrian Donahue New member Posts: 6,590 New member
    First, to be absolutely clear, you are using ANTS Performance profiler's "attach to a .NET 4 process" method? Because I can't see how this would reconfigure IIS, although if you use the regular "profile an ASP .NET web application in IIS" option, it attempts to copy and modify the IIS configuration and can cause problems like this because the host configuration had not been created correctly by Profiler.
  • Yup you are correct. Just tried it with the "attach to a .NET 4 process" and all good. Sorry about that should have seen it. Thanks for your help.
  • Brian DonahueBrian Donahue New member Posts: 6,590 New member
    Hello,

    A bit worrying if you can't get APP to launch the website, though.
  • Possibly, although I may have just been being a bit dim. I was trying to go to the .svc file and expecting the normal debug service screen. At least for my needs I think the "attach to a .NET 4 process" was the one I should have been using all along.
Sign In or Register to comment.