My application fails while running through Profiler

Hello:
I am running the profiler on a my .NET (Framework 1.1, C#) application. I can run the app fine without ANTS Profiler. The main module is a DLL, I tried accessing it through ASP.NET and WinForms. In both the cases it works fine without the profiler. However as soon as I run those using the profiler it fails and throws an exception.

I am quite sure this is related to security settings but could not find it. I have disabled Windows Firewall on my machine. I also tried to set "Run As" property of RedGate.Profiler.UI.exe, however it is not save it.

I am using trial version of ANTS Profiler 1.22 Build 137.

I would appreciate any help.
Arup.

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello Arup,

    Thanks for writing. Are you sure about the trial version number? We are currently on version 2.5. Would you mind having a look at http://www.red-gate.com and downloading the latest trial version?

    Aside from that, I've run into an issue this week with MySql that sounds similar -- MySql has some assemblies that help connect to the database system in .NET, and I believe these satellite assemblies couldn't be located under ANTS Profiler because the working directory property may have changed under ANTS Profiler. ANTS Profiler has a working directory text box that you can use to manually force this.
  • Thanks Brian for your help. I am now running Profiler version 2.5. However same exception is getting generated at the same line of code. I also tried to copy all DLLs in the working directory. That did not help ether.

    The line of code that is failing is in Data Access Layer of my application and I am using Oracle 10g.

    I appreciate your help.

    Arup.
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello,

    We're going to have to do some testing on this. In the other case of MySql, the error message indicates that resources could not be loaded for the proper culture (or culture-neutral). It's hard to say what the problem could be because we're 100% microsoft and do not normaly deal with Oracle or MySql code.
  • Brian, I did some more investigation today. I inserted trace messages along the execution path. I am little surprised to see that one of my DLL is not getting loaded. The DLL is present in the execution directory. A simple object initialization is failing:
    'GroupVO testGroupVo = new GroupVO("test");'.
    Trace message at the beginning of this constructor is not getting printed. I executed my app without profiler and it prints all trace messages.

    Arup.
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello Arup,

    Can you get the stack trace and innerexception from the error? The problem that we had with MySql was about a MissingManifestResourceException in the assembly. Apparently the MySql.Data.dll is culture-specific and needs to load resources for a particular culture. I wonder if you have the same issue.
  • Brian,
    I am using the debug build of my application and noticed that if I delete a specific PDB file from bin\debug directory everything works fine. When I leave that PDB file in debug directory, I am getting .NET standard security exception. I can safely use this workaround and in-fact I will be using release build soon. Profiler is returning expected result and I am all set.

    Arup.
  • Hi Arup

    Can you send over the information to [email protected] so that we can reproduce the problem here.
    It can then be escalated so a fix can be produced.

    Regards
    Dan
    Daniel Handley
    Red Gate Software Ltd
This discussion has been closed.