bad synchro : characters messed up

Hans Van EylenHans Van Eylen Posts: 9
I synchronized one table containing a Text column with the following definition on both servers :

[Text] [text] COLLATE SQL_Latin1_General_CP1_CI_AS NULL

The target table was empty so I expected them to be equal after the synchro but I found out that SQL Data Compare had changed some characters :

As an example, the source column contains :

"...the consultant<SPAN lang=ZH-CN>’</SPAN>s contract..."

This is changed to :

"...the consultant<SPAN lang=ZH-CN>’</SPAN>s contract..."

SQL Data Compare apparently translates from Unicode to UTF-8. There doesn't seem to be an option to keep the data in Unicode.

I solved the situation by running a simple update statement between the two servers, but that kind of defeats the purpose of SQL Data Compare.

Can you please look into this?

version :


This discussion has been closed.