Unable to profile

I have been using the profiler for many weeks with no problems. Suddenly I am not able to see any methods in any of my profiling sessions. Yes I am running a debug version, and yes the .pdb is in the same folder as the .exe. I created a simple "Hello World" application from scratch and am unable to profile it either. Any suggestions?

Thanks,
Nathan Wiegman
Sr. Software Engineer
Cascade Microtech Inc.

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello Nathan,

    Are you profiling a website/webservice or a desktop/console application, what version(s) of the .NET framework do you have installed, and if this is a website or service, what platform is this (Windows 2003)?

    This information will help us figure out which direction to take in troubleshooting this problem.
  • Hi Brian,

    It is a desktop application using Miscrsoft Development Environment 2003 (Version 7.1.3088) and Microsoft .NET Framework 1.1 (Version 1.1.4322 SP1).

    A side note that might be of use: right before this problem happened, I tried (just for kicks) to profile a release executable. When I switched back to using the debug executable, I was not able to profile any methods. I tried rebooting and starting from a clean workspace, but that didn't work either.

    Hope this Helps.

    Thanks,
    Nathan
  • Sorry, forgot...I am using C# and everything is in Windows XP with the most recent service packs and patches.
  • Hi there,

    just a thought but have you accidently disabled the profiler - there is a toggle button in the middle of the main toolbar for this. If the profiler is disabled everything will appear to run normally, but the results will always say No .NET Methods profiled. The fix is simply to enable the profiler :wink:

    Thanks,

    Tom
  • :shock:

    Thanks Tom,

    That did the trick.

    It is probably payback for all the times I have talked about the "stupid" users of our software. Operator error... :lol:

    Thanks a bundle,
    Nathan
This discussion has been closed.