Competition: What’s your favorite Redgate tool? Enter now.

Can not even start to Register server - Error

klewisklewis Posts: 4
edited August 31, 2005 9:37AM in DTS Compare 1.x
I get the following error when I click on the server drop down or it I type the server I get it when I click compare.

"The located assembly's manifest definition with name 'Interop.SQLDMO' does not match the assembly reference"

I do not have problems with SQL Compare or Sql data compare.

Could someone please help with this?

Thanks
Kelly

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello Kelly,

    More than likely this can be fixed simply by running the SQL Server CD and installing the client-side tools on the computer running DTS Compare. SQLDMO.dll is one of the libraries that comes with the SQL Server client side tools.
  • I reinstalled the client tools and restarted my computer and still get the same error message.

    Kelly
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi Kelly,

    There could still be a resource problem with the DMO DLL. Can you please try re-registering it? ('regsvr32 sqldmo.dll')
  • I uninstalled SQL Bundle and re-installed it that did not help. I then went to the location of the dll giving the problem deleted it and then did a repair on SQL bundle. I go the same error on another dll. I deleted it and did a repair. I continued deleting the dll and repairing SQL bundle until I no longer got the error.

    Everything is workin fine now.

    Kelly
This discussion has been closed.