WebService and WebSite tutorial sample apps are not working

JanetJanet Posts: 4
edited October 11, 2005 10:31AM in ANTS Load
OS: Windows XP Professional

A. Webservice

1. Installed Ants without IIS
2. Install IIS ver 5
3. Modify Ants installation adding in Tutorial Samples
4. I have .net framework 1.1 running on my machine.
5. Open browser and trying to go to http://localhost/ANTSLoadTutorialWebSer ... yeeDetails
6. I get this:
<%@ WebService Language="c#" Codebehind="Employees.asmx.cs" Class="ANTSLoadTutorialWebService.Employees" %>
7. The tutorial help has this instruction:
For example, click on the GetEmployeeDetails link, enter an employeeID of 1 and click on the 'Invoke' button. This makes a call to the web service and returns an XML file containing information about employee number 1.

Question: I don't see any invoke button and there is no way to enter employee ID

Something is not right. Has anyone of you encountered this problem? Can you help me?

Should I uninstall and install a fresh copy instead or are there other solutions?


B. Website
1. When I go to http://localhost/ANTSLoadTutorialWebSite/
2. I just see the banner.jpg with no link, buttons or anything. What can be tested from this sample application? There might be some objects missing.

Any help is much appreciated.

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi Janet,

    It sounds as if the ASP .NET code isn't running at all. This could be because the scriptmap is incorrect. Can you try this?

    Open a command prompt.
    Change directory to %systemroot%\Microsoft.net\Framework\v1.1.4322
    run aspnet_regiis -lk

    This will show the versions of ASP.net installed in each virtual directory. If you do not see ANTSLoadTutorialWebService or Website listed, use aspnet_regiis -sn to register it with ASP. net.
  • Hi Brian,

    I did the ff:

    1. went to c:\windows\microsoft.net\framework\v1.1.4322
    2. executed aspnet_regiis -lk
    3. returned "cannot find any installed versioin"
    4. went to c:\windows\microsoft.net\framework\v1.1.4322
    5. executed aspnet_regiis -sn c:\progra~1\ants load\tutorial\webservice or
    executed aspnet_regiis -sn c:\progra~1\ants load\tutorial\website
    6. returns me the aspnet_regiis help list

    Any advice?
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello Janet,

    You want to install ASP .NET on the virtual directory rather than the physical directory. So the command should be:
    aspnet_regiis -sn W3SVC/1/Root/ANTSLoadTutorialWebsite

    aspnet_regiis -sn W3SVC/1/Root/ANTSLoadTutorialWebService
    I think that should just about do the trick.
  • After Registering asp.net scripting for 1.1.4322.0 was successful, I checked
    c:windows\microsoft.net\framework\v1.1.4322 using aspnet_regiis -lk and the ff is included:

    w3svc/1/root/antsloadtutorialwebsite/ 1.1.4322.0
    w3svc/1/root/antsloadtutorialwebservice/ 1.1.4322

    But now when I try to access the tutorial sites e.g.
    http://localhost/antsloadtutorialwebsite or
    http://localhost/antsloadtutorialwebservice

    I get the page cannot be displayed http 500 - internal server error.

    I Restarted my Computer and tried it again, but I got the same error.

    Hmm... back to square one. : (. Any advice?
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Maybe simply starting over would get it working? Make sure that ASP .NET is installed by default with aspnet_regiis -i, then run the ANTS Load installation again, modify it to remove the samples, and run it again to re-install the samples.
This discussion has been closed.