What are the challenges you face when working across database platforms? Take the survey
Options

Nothing happens

Been a while since I used the Performance Profiler, just tried to run it and nothing happens. I've got 5.2.0.26 installed.

When I start the profiler from the VS 2008 ANTS5 menu, it shows up, it starts the exe, but nothing is recorded and the profiler window remains blank.

What am I doing wrong?
--
David Rutten
Robert McNeel & Associates

Comments

  • Options
    Brian DonahueBrian Donahue Posts: 6,590 Bronze 1
    Hello David,

    Does Performance Profiler work from the Start Menu? This would rule out Profiler itself as the cause so we could focus on the add-in.

    You may just want to use to from the start menu anyway if it works. Going through the add-in doesn't save you a significant amount of time anyway.
  • Options
    I get the exact same behaviour via the Start Menu. It starts the target exe (C++ MFC app), nothing is being recorded. I start my .NET plugin, nothing is being recorded. This used to work just fine, it's probably some settings I changed somewhere but don't remember.
    --
    David Rutten
    Robert McNeel & Associates
  • Options
    Brian DonahueBrian Donahue Posts: 6,590 Bronze 1
    ANTS Profiler doesn't connect until your application loads the .NET Framework. No MFC code is going to be profiled. Only the managed stuff.
  • Options
    ANTS Profiler doesn't connect until your application loads the .NET Framework. No MFC code is going to be profiled. Only the managed stuff.

    That's fine, I only care about the .NET code anyway. But even when my .NET plug-in is clearly up and running, ANTS is still blank.
    --
    David Rutten
    Robert McNeel & Associates
Sign In or Register to comment.