VirtualDiskSize parameter does not work to prevent Msg 3257

I followed the steps by adding the line in the Hyperbac.conf file and restarted the service. The log showed that it read the parameter but the new amount of 1500GB was not reported to SQL Server (2000 SP4). I changed the value to 100, restarted the service and the actual amount available was still reported.

Comments

  • Thank you for your post into the forum and sorry for the delay in replying.

    I little confused by your post.

    I suspect one of two things may have occurred, regarding the VirtualDiskSize parameter:

    1. The value given to the VirtualDiskSize parameter is too small so a bigger value needs to be set.

    OR

    2. Even when you set the VirtualDiskSize parameter, the actual amount of free disk space available is still insufficient to create the database compressed files.

    Another possibilty is that when you view the properties of the database, SQL still reports the files sizes as the orignal size.

    SQL Server is totally unaware of SQL Storage Compress or HyperBac processes being performed on the database files. So SQL Server will always believe that the database file sizes are the real uncompressed sizes.

    The only to check the actual compressed file sizes is to look at the properties for the actual files.

    Many Thanks
    Eddie
    Eddie Davis
    Product Support Engineer
    Redgate Software Ltd
    Email: [email protected]
  • We received a patched version and the parameter now works as stated in the documentation. The patch also took care of an issue where SQL Storage Compress was licensed but not the underlying Hyberbac which expired after two weeks.
Sign In or Register to comment.