What are the challenges you face when working across database platforms? Take the survey

Failed to launch trigger process on startup on 2008 x64

jacobtbjjacobtbj Posts: 3

I'm trying to start the ants memory profiler 6 on a windows 2008 x64 box and get the following error message after waiting a looong time (3-4 minutes)

Failed to launch trigger process.
at .?.(TriggerFlags )
at ??.


  • Options
    Just tried it on a different and completely clean 2008 x64 box and got the same error.

    I guess the conclusion is that ANTS memory profiler doesn't work on this configuration? :(


  • Options
    This configuration is supported: it's very similar to Windows Vista as far as the profiler is concerned.

    I've just tried this on one of our VMs running 2008 x64 and I can't reproduce the problem you are having, either by running the profiler as an administrator or a restricted user. We're using the Enterprise edition, but it's not clear if that could make a difference here.

    The trigger process is used for running tasks as different users and for attaching to processes running in WOW64. It's started automatically on 64-bit systems that have .NET 4 installed for this reason. The error you see occurs if it fails to contact the main UI after 30 seconds. It has been known to occur in our VMs if they are very heavily overloaded (as the process was taking more than 30 seconds to start)

    The trigger process is not run if you don't have .NET 4 and don't perform any actions that require elevation. It communicates with the UI via an IPC pipe.

    I'm assuming from your description that this problem is occurring before the 'start profiling' dialog is displayed (it's likely to be an elevation failure of some kind if it's happening later)

    Are you running ANTS as an administrator or a restricted user?
    If you're running as an administrator, is UAC turned on?
    If you have task manager running while you're starting the profiler, do you see the RedGate.Profiler.Trigger process starting? Has it quit or is it still running at the point that ANTS displays the error?
    If it's the _x86 variety of the trigger process, is it actually running as a 32-bit process? (This is a long shot, but if this was running 64-bit for some reason then you'd see this error)
    Andrew Hunter
    Software Developer
    Red Gate Software Ltd.
Sign In or Register to comment.