Recurring: 402: Failed to open local data store: data.sdf

mdgravesmdgraves Posts: 53
edited January 4, 2011 3:23AM in SQL Backup Previous Versions
I have Transactional backup running hourly, with full backup at 9 PM. yesterday, suddenly at 6 PM I started getting below error, and it has continued until this AM when I disabled job. Help!

ERRORS AND WARNINGS

8/18/2010 7:00:15 AM: SQL Backup process ended.

8/18/2010 7:00:15 AM: Deleted msdb entries older than 8/8/2010 7:00:15 AM
8/18/2010 7:00:18 AM: Warning 402: Failed to open local data store: Access to the database file is not allowed. [File name=C:\Documents and Settings\All Users\Application Data\Red Gate\SQL Backup\Data\(local)\data.sdf]

Comments

  • http://apps.red-gate.com/messageboard/v ... php?t=9243

    My instance is SQL 2000, so I couldn't load the SQL Server Compact Edition file into SSMS, so I renamed the troubled file.
  • Thank you for your post and sorry that you have encountered this problem.

    During the installation process for SQL Backup Server Components, our install process installs Microsoft SQL Server Compact Edition (SQL Server CE). This action creates a data.sdf file by default (If installing on stand-alone server) in this directory:
    C:\Documents and settings\All Users\Application Data\Red gate\SQL Backup\Data\<SQL Instance Name>\data.sdf

    This file act as a cache for the SQL Backup GUI, to improve the performance of the SQL Backup GUI. It is this file that is the Local Data Store.

    Can you kindly check following:
    Please check to see if you have a data.sdf present.
    If the file does exist, the file maybe corrupted, please perform the following actions:
    a. Close the SQL Backup GUI
    b. Rename the existing data.sdf, for example to olddata.sdf
    c. Reopen the SQL Backup GUI, this action should create a new data.sdf.

    Please let us know how it goes.
    Anuradha Deshpande
    Product Support
    Redgate Software Ltd.
    E-mail: [email protected]
  • I tried the file rename. All is fine. Thank you for the response.
  • Many thanks for the confirmation.

    We are pleased that your issue is resolved.
    Anuradha Deshpande
    Product Support
    Redgate Software Ltd.
    E-mail: [email protected]
  • Hi there,

    We are also getting this error, time and time again. Is there a problem with this cache?

    I have fixed the server more than once over about a three week period.
Sign In or Register to comment.