What are the challenges you face when working across database platforms? Take the survey
Options

GO capitalization issues

OliwaOliwa Posts: 42 Bronze 2
edited August 24, 2010 3:19PM in SQL Prompt Previous Versions
GO never seems to capitalize. If I type "g" and hit ENTER or TAB it capitalizes...but not if I type the word "go" and then hit ENTER. This is odd because it works with other keywords.

Comments

  • Options
    Can you go to the SQL Prompt Options (through the SQL Prompt menu) and look at the Format->Case page. Are all the options set to UPPERCASE?
  • Options
    OliwaOliwa Posts: 42 Bronze 2
    Yes, all options are set to uppercase. All other keywords capitalize as expected. If I type a "g" and hit ENTER it inserts "GO", and if I type "select" and hit TAB it capitalizes, but not "g".

    And I have TAB and ENTER set as activation keys.
  • Options
    Through some limited testing I have found that this seems to happen when the preceding statement has not been terminated by a semi-colon (;).

    for example:
    SELECT * FROM Person.Address
    go

    would instead come out as:
    SELECT * FROM Person.Address;
    GO

    is this the case with your situation?
  • Options
    OliwaOliwa Posts: 42 Bronze 2
    I tried what you suggested and whenever I had very simple scripts the capitalization worked fine, but I know I have scripts where "go" doesn't capitalize. I will respond with more information when I encounter the behavior again.
  • Options
    OliwaOliwa Posts: 42 Bronze 2
    I think I found a reproducible scenario...

    This is just one of the scenarios I found where go is not capitalized. There are others, but sometimes they work and other times not.

    If I declare a variable and type go afterward it capitalizes like so...
    DECLARE @var INT;{ENTER}
    go{ENTER}
    

    Now if I try putting in a USE statement before or after the batch go does not capitalize...
    USE master;{ENTER}
    go{ENTER}
    
    DECLARE @var INT;
    GO
    
    USE master;{ENTER}
    go{ENTER}
    

    But if I type "g" and hit ENTER it works.
  • Options
    To begin with when I tried to reproduce your example all of the 'go's capitalised as it should.

    However, I tried creating a new stored procedure to see if one named with 'go' could affect sql prompt. I named mine 'go_home' containing a very simple select statement. After creating it, I retried your example and that was when I got the results that you describe.

    Can you confirm for me whether you have a stored procedure (or any other object) that could be interfering in this way? If you do, can you try dropping it and then re-testing your example. Do you get the same results?
  • Options
    OliwaOliwa Posts: 42 Bronze 2
    I do not have any objects starting with "go". Next time it happens I'll see if there is any objects named similarly.
Sign In or Register to comment.