Problem with e-mail

rlindsayrlindsay Posts: 17
edited August 15, 2005 11:49AM in SQL Backup Previous Versions
I am currently evaluating SQL Backup but am having trouble getting the mail notification to work. When I set the mail settings (smtp host and e-mail from) in options and click test I get an error box saying
Failt to send email - (Failed to connect to mail server). I have tried a local smtp server and one at my ISP with no luck and I can telnet into both these servers on port 25.

Any help appreciated.

Comments

  • peteypetey Posts: 2,358 New member
    Did you check if your smtp server requires authentication? Also try using the IP address of the smtp server instead of the host name.
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
  • Already checked - the SMTP server doesn't require authentication and have tried using IP instead of name.
  • peteypetey Posts: 2,358 New member
    Strange. Any firewall/router rules preventing SQL Backup from connecting externally to port 25 because it's not a recognized e-mail client?
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
  • No, nothing preventing external access and it doesn't work with a local SMTP server either. The fact that I can telnet to the local and external SMTP servers also indicates that it isn't a firewall issue.
  • peteypetey Posts: 2,358 New member
    Try renaming telnet.exe to sqlbackup.exe, and see if you can still connect to the smtp server using this renamed telnet app.
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
  • Using the renamed file to telnet to SMTP servers works OK.
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello,

    You may want to try enabling logging for the SMTP server and find the reason for failure there. In IIS and Exchange, it's a matter of looking at the properties of the SMTP virtual server, and clicking the 'enable logging' checkbox. This will write a text log to (default) %SYSTEMROOT%\system32\logfiles\smtpsvc1.

    If you are using your site's Exchange server to send mail, you will most likely have the IP addresses which can relay mail limited as much as possible. You'll want to make sure that the mail server allows relay from your SQL Server's IP address.
  • I already have logging turned on for my local SMTP virtual server and there are no log file entries generated.

    I do use a few different network cards in this laptop - could it be trying to use a device that isn't available?
  • peteypetey Posts: 2,358 New member
    >> I do use a few different network cards in this laptop - could it be trying to use a device that isn't available?

    Perhaps. Did you try disabling the non-active NICs' and see if SQB can contact the SMTP server?
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
  • I have disabled all of the NICs apart from the current acive NIC but it still doesn't work.
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Maybe the SMTP virtual server isn't listening on the correct interface. That certainly would explain why there is no SMTP log. Even if the client connects and simply says HELO there should be something in that log.

    Have you though about looking at the SMTP virtual server configuration and changing the address to 'All Unassigned'?
  • Its currently on 'All Unassigned' and I do get activity in the log if I telnet into the server and can complete a full mail session, I just don't get activity when using the SQL Backup utility and the error message appears.
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Have you tried telling SQL Backup to use the IP address of the other network interface?
  • Brian,

    There is only one interface enabled and the problem also happens with external SMTP servers. The problem seems to be with SQL Backup picking the correct interface to use for communications.
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello,

    Just checking, but is Peter working with you directly on this issue now?
  • Brian,

    Yes he was but haven't heard anything since Friday morning.
Sign In or Register to comment.