What are the challenges you face when working across database platforms? Take the survey
Options

Ignore identity not working?

andrewhopkinsonandrewhopkinson Posts: 4
edited August 2, 2010 12:16PM in SQL Compare Previous Versions
Hi, I have set my options to ignore identities and seeds, yet it still is picking up these differences. Basically, I have a data warehouse where I wipe and download data daily, so I have turned off all identity seeds for the tables. I want SQL Compare to ignore these columns, how do I do that? thanks.

Comments

  • Options
    Thanks for your enquiry.

    Unfortunately there isn't a way to ignore specific columns in the current version of SQL Compare. This includes any identity columns or rowguid columns. If you compare a table, all columns will be included in the comparison.

    We have a feature request in place to allow a greater deal of control, basically allowing you to treat a column as an object in its own right. This will also be the same for permissions, triggers, indexes etc. The feature number for this is SC-2447 and I have added you as another vote for the feature.

    The option to ignore identity seed and increment values is just to allow you to not synchronize the difference in the configuration of the identity column. For example, if you have a IDENTITY (1,1) in Db1 and IDENTITY (3,8) in Db2, this option would ignore this difference. However, if the table is synchronized for another reason, these settings will be synchronized too.

    I hope this helps.
    Chris
Sign In or Register to comment.