What are the challenges you face when working across database platforms? Take the survey

One or more messages couldn't be archived etc.

CPHargraveCPHargrave Posts: 5
edited August 4, 2010 8:47AM in Exchange Server Archiver
Hi - Just installed ESA v3.0 yesterday and ran my first archivals with some errors...

From ArchiveService an error is thrown...
DotMessageArchiving - one or more messages couldn't be archived...
I have found where the logs are but there's quite a bit in there. I am in the neighborhood of the timestamp of the message but still not easily finding any detail to assist locating the one message that didn't make it. What should I be looking for? Where should I be looking?
The Archive Service then threw an error that it couldn't connect to the exchange store - but it just had ???

Then I ran another archival job against different mailboxes. Here I get several similar warnings thrown from StorageService ...
StorageServiceFilter - Couldn't load item - skipping file e:\<archivepath>\<user-guid?>\biglongfilenameperhapsmessageid.esa2
But when this archival job ended, there was no indication that any messages did not make it as above. The biglongfilename does not exist in the archive store. How can I determine what the problem messages are?

Thanks in advance,


  • Options
    Hi Charlie,

    Regarding the Archive Service error: there should be a debug message in the Archive Service log file (which I think you've already found - if not, have a look at this link) along the lines of "Error thrown in folder <foldername> message <messagesubject>". That'll give you an indication of which message caused the error.

    It's quite possible that a subsequent run of the archive job will archive this message successfully; if the same message fails multiple times, the first thing to do is check whether you can open it in Outlook. We've found that sometimes messages are corrupted in the Exchange Information Store such that even opening them in Outlook causes an error. If Outlook is able to open the message, please do let us know - it's something we can investigate further.

    The Storage Service error: you're pretty close with your guesses of those filenames! Within the store, the folder name corresponds to the Exchange mailbox GUID; the filename of the .esa2 file is our message unique identifier and the ID of the file that contains the message body (.esa2 files are the result of single instancing, and don't contain the body, but a pointer to a .esa file where the body is stored).

    If that file doesn't exist, I'm surprised. Windows Indexing Service is the thing that determines the list of files on disk that we need to index, so if the file isn't present, I'm not sure how Indexing Service told us to index it. It might be worth checking whether any virus scanner on the machine has quarantined the file?

    Many thanks,
    Robert Chipperfield
    Red Gate
  • Options
    Hi Charlie,

    I wonder how you got on with the suggestions above? Do let me know if you're still seeing an issue that we can help with!

    Robert Chipperfield
    Red Gate
  • Options
    Hi Robert - sorry I'm not actively evaluating ESA as much as I'd like and still am perplexed regarding finding specific failed messages - I can determine the user from the folder name but the specific message e.g. ef4e8c83-f27e-4437-b656-b3a64245fd13.esa doesn't tell me much about how to locate the particular message other than viewing the contents iof the file and then searching for that in the user's instance of outlook - am I missing the easy way?

    During an archive job I get occasional instances of:
    Cannot contact Exchange information store. This may be because:
    - Exchange is not running
    - network error communicating with the Exchange server
    - mailbox database has been dismounted
    - the Archive Service user’s account has been disabled or deleted ---> System.Runtime.InteropServices.COMException (0x80040115): Exception from HRESULT: 0x80040115
    This can occur in the middle of the archive job - so none of the reasons listed in the log message can be true as archiving is continuing. What's up?

    Another issue looks scary - saw that an archive store needed repair and tried to - here's the log info:
    16:09:59.215|Info |Storage Engine |8 |Repair Archive Store started for 'WIAStore'
    16:09:59.230|Verbose|MetaStore |8 |Loaded MetaStore 17ef93c8-a684-4a31-908b-21eb1839b73d C:\WINDOWS\TEMP\d4a11755-2251-4bbc-80a0-f2c6bde2de80\meta.db
    16:10:02.324|Verbose|Storage Engine |8 |Pass 0 - Repairing folder c:\archivestore\WIAStore\4b153e1b-c778-4298-924d-f91f99465b7b
    16:10:29.230|Verbose|Storage Engine |9 |GetServiceDetail
    16:10:29.230|Verbose|Storage Engine |9 |DocumentsIndexed: 65512
    16:10:29.230|Verbose|Storage Engine |9 |DocumentsToIndex: 0
    16:10:59.324|Verbose|Storage Engine |9 |GetServiceDetail
    16:10:59.324|Verbose|Storage Engine |9 |DocumentsIndexed: 65512
    16:10:59.324|Verbose|Storage Engine |9 |DocumentsToIndex: 0
    16:11:19.089|Verbose|Storage Engine |8 |Pass 0 - Repairing folder c:\archivestore\WIAStore\645012be-5df2-4a09-881c-9cca7fa80f2c
    16:11:20.886|Verbose|Storage Engine |8 |Pass 0 - Repairing folder c:\archivestore\WIAStore\81afc59b-1350-4ffd-8464-222f13f62c4d
    16:11:29.402|Verbose|Storage Engine |9 |GetServiceDetail
    16:11:29.402|Verbose|Storage Engine |9 |DocumentsIndexed: 65512
    16:11:29.402|Verbose|Storage Engine |9 |DocumentsToIndex: 0
    16:11:32.480|Verbose|Storage Engine |8 |Pass 0 - Repairing folder c:\archivestore\WIAStore\af571dcb-2d86-4d07-a36d-950d0b523b30
    16:11:59.479|Verbose|Storage Engine |9 |GetServiceDetail
    16:11:59.479|Verbose|Storage Engine |9 |DocumentsIndexed: 65512
    16:11:59.479|Verbose|Storage Engine |9 |DocumentsToIndex: 0
    16:12:09.729|Verbose|Storage Engine |8 |Pass 0 - Repairing folder c:\archivestore\WIAStore\d1f6c2ce-a087-4d88-a2dd-1f699d3778c7
    16:12:29.557|Verbose|Storage Engine |9 |GetServiceDetail
    16:12:29.557|Verbose|Storage Engine |9 |DocumentsIndexed: 65512
    16:12:29.557|Verbose|Storage Engine |9 |DocumentsToIndex: 0
    16:12:49.463|Verbose|Storage Engine |8 |Pass 1 - Repairing folder c:\archivestore\WIAStore\4b153e1b-c778-4298-924d-f91f99465b7b
    16:12:50.979|Verbose|Storage Engine |8 |Pass 1 - Repairing folder c:\archivestore\WIAStore\645012be-5df2-4a09-881c-9cca7fa80f2c
    16:12:51.182|Verbose|Storage Engine |8 |Pass 1 - Repairing folder c:\archivestore\WIAStore\81afc59b-1350-4ffd-8464-222f13f62c4d
    16:12:51.463|Verbose|Storage Engine |8 |Pass 1 - Repairing folder c:\archivestore\WIAStore\af571dcb-2d86-4d07-a36d-950d0b523b30
    16:12:52.276|Verbose|Storage Engine |8 |Pass 1 - Repairing folder c:\archivestore\WIAStore\d1f6c2ce-a087-4d88-a2dd-1f699d3778c7
    16:12:53.057|Verbose|Storage Engine |8 |Pass 2 - Repairing folder c:\archivestore\WIAStore\4b153e1b-c778-4298-924d-f91f99465b7b
    16:12:59.635|Verbose|Storage Engine |9 |GetServiceDetail
    16:12:59.635|Verbose|Storage Engine |9 |DocumentsIndexed: 65512
    16:12:59.635|Verbose|Storage Engine |9 |DocumentsToIndex: 0
    16:13:29.713|Verbose|Storage Engine |9 |GetServiceDetail
    16:13:29.713|Verbose|Storage Engine |9 |DocumentsIndexed: 65512
    16:13:29.713|Verbose|Storage Engine |9 |DocumentsToIndex: 0
    16:13:59.791|Verbose|Storage Engine |9 |GetServiceDetail
    16:13:59.791|Verbose|Storage Engine |9 |DocumentsIndexed: 65512
    16:13:59.791|Verbose|Storage Engine |9 |DocumentsToIndex: 0
    16:14:08.994|Verbose|Storage Engine |8 |Pass 2 - Repairing folder c:\archivestore\WIAStore\645012be-5df2-4a09-881c-9cca7fa80f2c
    16:14:09.088|Trace |Storage Engine |8 |Cannot repair attachment d98b3f68-998b-49ec-a20a-2df63905875b in message c:\archivestore\WIAStore\645012be-5df2-4a09-881c-9cca7fa80f2c\1a8c52dd-c99b-4407-8c08-2af87f4354ae.esa
    16:14:09.385|Trace |Storage Engine |8 |Cannot repair attachment e839b7e0-54ab-4d97-97d0-25f3713a60af in message c:\archivestore\WIAStore\645012be-5df2-4a09-881c-9cca7fa80f2c\43d32d16-1051-4480-939f-2fa128d64272.esa
    16:14:09.775|Trace |Storage Engine |8 |Cannot repair attachment cb265314-4955-4dd7-a94c-b8db460a4776 in message c:\archivestore\WIAStore\645012be-5df2-4a09-881c-9cca7fa80f2c\9bdcd69d-9924-48d7-b963-692ac5784b35.esa
    16:14:09.807|Trace |Storage Engine |8 |Cannot repair attachment 6ec201a5-8b24-4ee1-a01b-426b72d470bf in message c:\archivestore\WIAStore\645012be-5df2-4a09-881c-9cca7fa80f2c\a3c882b7-504c-444f-8619-f6f931bc045e.esa
    16:14:09.979|Trace |Storage Engine |8 |Cannot repair attachment e6c2fbc1-1eed-4609-8f04-148bdea6e0ef in message c:\archivestore\WIAStore\645012be-5df2-4a09-881c-9cca7fa80f2c\dcf16bb2-bd29-4a40-a72e-60be8a914826.esa
    16:14:10.041|Trace |Storage Engine |8 |Cannot repair attachment 0994b926-05e4-4f35-8fc2-37710c7cff46 in message c:\archivestore\WIAStore\645012be-5df2-4a09-881c-9cca7fa80f2c\ef4e8c83-f27e-4437-b656-b3a64245fd13.esa
    16:14:10.072|Trace |Storage Engine |8 |Cannot repair attachment 9c242cb1-ce22-4845-becf-f1d474506587 in message c:\archivestore\WIAStore\645012be-5df2-4a09-881c-9cca7fa80f2c\fa503efb-92ca-416a-96b7-6df8aa2341f4.esa
    16:14:10.854|Verbose|Storage Engine |8 |Pass 2 - Repairing folder c:\archivestore\WIAStore\81afc59b-1350-4ffd-8464-222f13f62c4d
    16:14:13.869|Verbose|Storage Engine |8 |Pass 2 - Repairing folder c:\archivestore\WIAStore\af571dcb-2d86-4d07-a36d-950d0b523b30
    16:14:29.869|Verbose|Storage Engine |9 |GetServiceDetail
    16:14:29.869|Verbose|Storage Engine |9 |DocumentsIndexed: 65512
    16:14:29.869|Verbose|Storage Engine |9 |DocumentsToIndex: 0
    16:14:41.119|Verbose|Storage Engine |8 |Pass 2 - Repairing folder c:\archivestore\WIAStore\d1f6c2ce-a087-4d88-a2dd-1f699d3778c7
    16:14:59.947|Verbose|Storage Engine |9 |GetServiceDetail
    16:14:59.947|Verbose|Storage Engine |9 |DocumentsIndexed: 65512
    16:14:59.947|Verbose|Storage Engine |9 |DocumentsToIndex: 0
    16:15:10.572|Verbose|Storage Engine |8 |Pass 3 - Repairing folder c:\archivestore\WIAStore\4b153e1b-c778-4298-924d-f91f99465b7b
    16:15:12.838|Verbose|Storage Engine |8 |Pass 3 - Repairing folder c:\archivestore\WIAStore\645012be-5df2-4a09-881c-9cca7fa80f2c
    16:15:13.478|Verbose|Storage Engine |8 |Pass 3 - Repairing folder c:\archivestore\WIAStore\81afc59b-1350-4ffd-8464-222f13f62c4d
    16:15:13.494|Verbose|Storage Engine |8 |Pass 3 - Repairing folder c:\archivestore\WIAStore\af571dcb-2d86-4d07-a36d-950d0b523b30
    16:15:14.509|Verbose|Storage Engine |8 |Pass 3 - Repairing folder c:\archivestore\WIAStore\d1f6c2ce-a087-4d88-a2dd-1f699d3778c7
    16:15:16.041|Verbose|Storage Engine |8 |Finished repairing - replacing meta dbs
    16:15:16.056|Verbose|MetaStore |8 |ReleaseMetaStore 17ef93c8-a684-4a31-908b-21eb1839b73d
    16:15:16.088|Warn |Storage Engine |8 |Repair Archive Store completed for 'WIAStore'; some data files are missing.
    Some archived messages will not be accessible.
    Restore missing data files from backup.
    It's the "some data files are missing" which alarms me. It would be nice to have a list or at least a count. Is it those errors I see regarding attachments? I'm evaluating and in "Copy entire message" mode so I know I haven't lost anything - yet. I killed the archive and started over and haven't seen a need for repair yet so unsure if I can duplicate this.

    I guess I have questions/problems that are tough to describe accurately in the forum. I tried calling the tech support line for ESA USA / Canada: 1 877 883 7969 (toll free) about 30 minutes ago but thought I'd leave this note before whining to voicemail. What's a better time to call? I'm in Chicago CDT GMT-6.

    Thanks in advance for your help so far and in the near future,
    Charlie Hargrave
  • Options
    I've installed all components of ESA on my exchange server 2007sp1 - no outlook installed - MAPI/CDO reports v6.5.8165.0.
  • Options
    OS Windows 2003R2 Standard SP2
    Exchange 2007sp1 v8.01.0436.000
  • Options
    Hi Charlie,

    Sorry for the delayed reply - I've just raised a couple of support calls for the two issues here (the archiving error, and the warning from the repair store operation).

    You should have received a couple of emails with the call reference numbers in - please let me know if not.

    I'll reply to those calls in a moment.

    Robert Chipperfield
    Red Gate
Sign In or Register to comment.