What are the challenges you face when working across database platforms? Take the survey
Options

'Restore' select backup history never populates.

bbingaybbingay Posts: 8
edited June 28, 2010 3:59PM in SQL Backup Previous Versions
I have the latest SQL backup version 6.4.0.56. When I chose 'Select from backup history' The retrieving backup history animation just keeps spinning. Does anyone know why? I can select individual files with no problem.

Windows 2008 64Bit standard SP2
SQL 2008 64bit

Comments

  • Options
    Hi there,

    Many thanks for your post. This is a known issue regarding the GUI when either or a multitude of the following is true:

    1) You are not deleting any existing backup history
    2) You have a large number of databases on that server
    3) You have backup jobs of any description running regularly, i.e. every 15 mins

    All of these factors contribute to the SQL Backup Activity History, which is what is used to populate backups for restoring being slow to appear. The architecture of the tool means that it reads backup history through a data.sdf file (CE database) on the server itself which in turn pulls backup history from the MSDB database.

    If SQL Backup is retrieving a lot of history, then the population takes a while to complete. To combat this, you can select to delete backup history from the server by clicking on a server and then going to Tools > Server Options and setting to delete SQL Server Backup history after X amount of days. You could of course, as you have noted, just select the relevant files you want to restore.

    We do however alrady have an issue open internally for this under tracking number SB-4400, which will be reviewed for the next release of the tool. Unfortunately though I am not at this time in a position to tell you when that is likely to be.

    Pete
    Peter Peart
    Red Gate Software Ltd
    +44 (0)870 160 0037 ext. 8569
    1 866 RED GATE ext. 8569
  • Options
    Thanks for the reply, I have a t-log backup happening every 5 minutes. My history is set to 90 days. Picking the files manually is not a problem. Thanks again for the information.
Sign In or Register to comment.