One table that can not be compare

laudetlaudet Posts: 3
Hi.
I have been using Data compare for over 6 month now and it was always working fine. The process we do with the DB is making copies of the DB, work on the copies, then synchronize them with the original one (the DB is not on a network).
Last week, I added a table to the original DB, but when the time comes to compare data, this new table got the "1 table or view that cold not be compared" message and I have to synchronize manualy.
I did a test: making a copy on an instance of SQL on the same machine and did a compare immediately after attaching the copy. Same error!
How do you explain that?
Tilew

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi,
    The message "table or view cannot be compared" means that there is no viable, matching primary key or unique index on the table. In that case, the comparison key column has to be set manually in the "tables & views" tab.
  • Yup! that was exactly the problem: I forgot to put a primary key in the table!
    I fixed it and it works fine now. Thanks!
    Tilew
Sign In or Register to comment.