Error: The web application has not loaded the .NET Framework

I've gone through the wizard and have selected Performance profiling, ASP.NET application, and have provided the URL of the home page of the site. It does the restarting of IIS etc, and then launches Internet Explorer on the indicated site running on localhost. I click "Snapshot" to reset the counters and I then get this error:

The web application blahblahblah has not loaded the .NET framework. Please check that blahblahblah is an ASP.NET web application. Please note that accessing cached web pages will not load the .NET framework.

It is an ASP.NET application and I have been able to profile it previously using the ANTS profiler.

Any ideas?

Comments

  • Hi

    Can I check with you that the application is hosted on the same machine that you are running profiler, and that you are selecting the URL form the dropdown list rather than just typing it in.

    Regards
    Dan
    Daniel Handley
    Red Gate Software Ltd
  • I can't give you the exact URL in this forum as it contains my company name and the customer's name, but it's along the lines of http://localhost/myname/custname/default.aspx and I'm getting it from the drop-down.

    I've tried both the option to profile code with source and all .NET code, both give the same error. I've tried different projects, same problem. It's all compiled in debug mode.
  • Hi,

    my name is Tom Harris; I'm responsible for the development of ANTS Profiler here at Red Gate. Could you answer a few standard questions for us -
    1) What operating system are you running (including any service packs)?
    2) What version of the .NET Framework does your ASP.NET application run against?
    3) What other versions of the .NET Framework are installed on your machine?
    4) What version of IIS are you running?

    Also, could you enable ANTS Profiler logging by creating the directory C:\Program Files\Red Gate\ANTS Profiler\Logs. All logs will be created in this directory.

    To get logging for ASP.NET profiling you will need to stop and restart the ANTS Profiler service from the control panel. Could you please send the log file servicelog.txt through to [email protected]

    Best regards,

    Tom Harris
  • I incidently wouldn't be surprised if this problem has to do with my having installed Visual Studio 2005 Beta 2 and .NET 2.0. I didn't have it installed the last time I successfully ran the profiler. I have 1.0, 1.1, and 2.0 installed on my machine.

    I followed your steps but didn't get a log file.

    1. Windows XP Professional SP2
    2. I'm using VS 2003 so I'm assuming I'm compiling and running against 1.1. Sites run fine on other machines that don't have 2.0.
    3. 1.0.3705, 1.1.4322, and 2.0.50215
    4. IIS 5.x (I don't know how to get the exact version number)
  • Hi,

    thanks for the details. You are probably not getting a log file because the ASPNET user account does not have disk write access. The ANTS Profiler service runs under the ASPNET user account. Please use the control panel to change the priviliges.

    You may well be correct that having .NET 2.0 beta installed is causing the problem. Only the log file will tell us for sure.

    Thanks,

    Tom
  • Hi, before start profiling you must delete ASPNet temporary folder for actually testing application (e.g. C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\Temporary ASP.NET Files\[MyAppName])
  • Hi Hulit,

    there is no need to go in and delete the compiled ASP.NET assemblies from the Framework directory - ANTS Profiler will simply profile them when they are loaded up by the CLR.

    Many thanks for your input though,

    Tom
  • The service runs under the local system account when installed. I seem to recall it has lower privileges these days so I changed the account to my own, which has admin rights. After doing that, the site doesn't work at all. After going through the wizard and it kicks off Internet Explorer on the home page, it gives me a "500". The site works fine if I don't run it through the profiler.

    There is nothing in the logs directory.
  • Hi,

    please check your private messages. I have sent you more detailed instructions.

    Thanks,

    Tom
This discussion has been closed.