Error on Startup

Hi

I'm running XP Pro and .Net 1.1 and I get the following error when I start the Application:

Eine nicht behandelte Ausnahme des Typs 'System.ComponentModel.Win32Exception' ist in system.dll aufgetreten.

Zusätzliche Informationen: Der angegebenen Datei ist keine Anwendung zugeordnet








'RedGate.Profiler.UI.exe': 'c:\windows\microsoft.net\framework\v1.1.4322\mscorlib.dll' geladen, keine Symbole geladen.
'RedGate.Profiler.UI.exe': 'C:\Programme\Red Gate\ANTS Profiler\RedGate.Profiler.UI.exe' geladen, keine Symbole geladen.
'RedGate.Profiler.UI.exe': 'c:\windows\assembly\gac\system.windows.forms\1.0.5000.0__b77a5c561934e089\system.windows.forms.dll' geladen, keine Symbole geladen.
'RedGate.Profiler.UI.exe': 'c:\windows\assembly\gac\system\1.0.5000.0__b77a5c561934e089\system.dll' geladen, keine Symbole geladen.
'RedGate.Profiler.UI.exe': 'c:\windows\assembly\gac\system.drawing\1.0.5000.0__b03f5f7f11d50a3a\system.drawing.dll' geladen, keine Symbole geladen.
'RedGate.Profiler.UI.exe': 'c:\programme\red gate\ants profiler\redgate.profiler.engine.dll' geladen, keine Symbole geladen.
'RedGate.Profiler.UI.exe': 'c:\programme\red gate\ants profiler\redgate.licensing.client.dll' geladen, keine Symbole geladen.
'RedGate.Profiler.UI.exe': 'c:\programme\red gate\ants profiler\devexpress.xtrabars.dll' geladen, keine Symbole geladen.
'RedGate.Profiler.UI.exe': 'c:\programme\red gate\ants profiler\devexpress.utils.dll' geladen, keine Symbole geladen.
'RedGate.Profiler.UI.exe': 'c:\programme\red gate\ants profiler\devexpress.xtratreelist.dll' geladen, keine Symbole geladen.
'RedGate.Profiler.UI.exe': 'c:\programme\red gate\ants profiler\devexpress.xtraeditors.dll' geladen, keine Symbole geladen.
'RedGate.Profiler.UI.exe': 'c:\windows\assembly\gac\system.data\1.0.5000.0__b77a5c561934e089\system.data.dll' geladen, keine Symbole geladen.
'RedGate.Profiler.UI.exe': 'c:\programme\red gate\ants profiler\actiprosoftware.dockablewindow.dll' geladen, keine Symbole geladen.
'RedGate.Profiler.UI.exe': 'c:\programme\red gate\ants profiler\actiprosoftware.tabstrippanel.dll' geladen, keine Symbole geladen.
'RedGate.Profiler.UI.exe': 'c:\windows\assembly\gac\system.xml\1.0.5000.0__b77a5c561934e089\system.xml.dll' geladen, keine Symbole geladen.
'RedGate.Profiler.UI.exe': 'c:\programme\red gate\ants profiler\redgate.licensing.helper.dll' geladen, keine Symbole geladen.
'RedGate.Profiler.UI.exe': 'c:\programme\red gate\ants profiler\devexpress.xtragrid.dll' geladen, keine Symbole geladen.
Eine nicht behandelte Ausnahme des Typs 'System.ComponentModel.Win32Exception' ist in system.dll aufgetreten.

Zusätzliche Informationen: Der angegebenen Datei ist keine Anwendung zugeordnet

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello,

    This sounds roughly equivilent to the 'not a valid Win32 application' error that we get in the English version of .NET with Profiler.

    Can you tell me, have you got the latest version of ANTS Profiler 2.5? If it hasn't been fixed in 2.5, there is probably some updated files that we can send to fix the problem.
  • Hi,

    I just downloaded the current version and tryed to start it, but same error.
    Translated into english the error means "There is no associated application for the given file"
  • Hi,

    my name is Tom Harris; I'm responsible for the development of ANTS Profiler here at Red Gate. From your callstack I cannot really see what might be causing the problem. Is the error happening when you a) start ANTS Profiler, or b) when you try and start profiling your application? If the answer is b) and you are profiling ASP.NET then please try the following

    At the command line type regsvr32 shdocvw.dll

    If this does not fix the problem then please let us know exactly what you are doing to cause the error.

    Best regards,

    Tom Harris
  • Hi,

    it happens when i start ANTS Profiler. I see the splash screen, then the toolbars are coming and when the splashscreen should go away, the exception gets throwed. Maybe it's a problem with the DevExpress Component?
  • Hi there,

    this is the first time we have had a problem with getting ANTS Profiler started. I'm afraid that I can only offer some basic ideas. Could you completely uninstall any version of ANTS Profiler that you have currently installed? Next, delete the directory C:\Program Files\Red Gate\ANTS Profiler and then reinstall ANTS Profiler 2.5 again.

    I'm sorry that I can't offer anything more concrete but we have not seen anything like this before. We will conduct some testing here to see if we can reproduce the crash.

    Regards,

    Tom
  • Hi there,

    we have tested this on a machine running German version of XP Pro with .NET 1.1. ANTS profiler runs normally. I'm afraid that I am still no wiser as to what might have gone wrong on your particular machine.

    Regards,

    Tom
This discussion has been closed.