Competition: What’s your favorite Redgate tool? Enter now.

Column Mapping Issue

RodCRodC Posts: 8 Bronze 1
When I am unmapping columns, each time I unmap one column, the whole column list reorders itself in some arbitrary manner. This is quite annoying when I have tables with 100's of fields (Thank you MSCRM!!!)

Is this a bug\feature or is there something I am missing?

I am Using SQL Data Compare 8.0.2.5.

Comments

  • Hi Rod,

    Many thanks for your post.

    I have tried this with the latest patched version and I can't seem to rectify the behaviour (unless of course I am misunderstanding).

    Can you try the latest cumulative patch available from below and let me know how you get on?

    http://www.red-gate.com/messageboard/vi ... php?t=9880

    Many thanks!

    Pete
    Peter Peart
    Red Gate Software Ltd
    +44 (0)870 160 0037 ext. 8569
    1 866 RED GATE ext. 8569
  • RodCRodC Posts: 8 Bronze 1
    I applied the patch and the issue is still there.

    Here are three screenshots that show the problem

    sqlCompareIssue1.png
    sqlCompareIssue2.png
    sqlCompareIssue3.png

    As you can see, I unmapped the CreatedOn field and the fields all reordered themselves in an arbitory manner.

    I think it would be better if they all where presented in alpha order and stayed that way.

    Cheers.
  • Hi Keith,

    I am still having issues replicating this.

    Can I ask, were these the default mappings that SQL Data Compare originally set that you are altering?

    From what I can tell, SQL Data Compare orders the columns in the order that they appear from the original underlying table. I am wondering if this has something to do with the column order in the original DB's being different at all.

    Many thanks!

    Pete
    Peter Peart
    Red Gate Software Ltd
    +44 (0)870 160 0037 ext. 8569
    1 866 RED GATE ext. 8569
  • RodCRodC Posts: 8 Bronze 1
    Not sure who Keith is, but for my case, the entities I am comparing are views from a Microsoft CRM database.
    The Left side is a back up that was restored into a separate sql database and the right side is the "live" database.

    The views are identical (and explicit) in field order. The SQL data compare field list is not in the same order as the view.

    I am attempting to exclude a number of columns from the comparison as the comparison returns false positives if these fields are included.

    Each view can have several hundred columns and the full (uncompared) dataset can have millions of rows.

    I have been able to unmap the columns, but it is a real trial when I have to go to the top of the column list each time and carefully scroll through to find the next column to unmap. At which point the column list reorders itself and I have to start at the top again.

    It would be good if there was some way to order the columns (like the result set allows) and for the column list to stay in that order.
  • Hi Rod,

    Sorry for calling you Keith!

    Anyway, for me to attempt to reproduce this, I would really need copies of your databases (backup files) and your SDC project file, as I can't seem to replicate this behaviour here.

    If it you are wishing to just exclude some columns from a comparison, is there any reason you are unmapping them rather than excluding them per under the Tables and Views tab? If you open this up and then click Columms in the comparison on the right hand side, you can exclude columns with by using the checkbox.

    Pete
    Peter Peart
    Red Gate Software Ltd
    +44 (0)870 160 0037 ext. 8569
    1 866 RED GATE ext. 8569
Sign In or Register to comment.