What are the challenges you face when working across database platforms? Take the survey

SMSS freezes after being connected to another db engine

HÃ¥kan BHÃ¥kan B Posts: 12
edited March 8, 2010 4:55AM in SQL Prompt Previous Versions
When I connect to another database engines than my own (could be via VPN or not), do some work and then disconnects.
If I then goes on to work on another database engine it just freezes for a long time.
During this time one can see two instances of Microsoft SQL Server Management Studio on the Program tab in Task Manger. When an error message appears in SSMS one of the instances disappears.

What’s interesting is that the error message refers to the database engine I earlier disconnected. So when I connect to a new database engine SQL Promt (or SQL Search or both) automatically seems to connect and starts gathering information in the background. But it doesn’t seem to be aware when the user disconnects from the database engine and still tries to hold a reference to that particular database engine.

Usually I right click on a database engine and choose “Disconnect”.
Directly after that I for example right click a Stored procedure in my own database engine.

I wonder if the right click I do when I Disconnect somehow leads SQL Promt or SQL Search to believe that the disconnected Database engine is the one “in play”?

I will cross post this in both SQL Promt and SQL Serach since it is not obvious where the problem is.


  • Options
    Anu DAnu D Posts: 876 Silver 3
    Many thanks for your post and apologies for the inconvenience caused.

    Can you kindly send us the error message that you get in your SSMS?

    And also let us know what exact steps you follow as soon as you right click and disconnect first database and open the new query window for new database?

    The above steps will help us to understand the issue more clearly and also will help us to replicate it at our end.
    Anuradha Deshpande
    Product Support
    Redgate Software Ltd.
    E-mail: support@red-gate.com
Sign In or Register to comment.