Deadlocks show message- This alert is still being written to

neelymdneelymd Posts: 10
edited March 11, 2010 4:32AM in SQL Monitor Previous Versions
The detail for Deadlocks is not being completed, it only shows this message - "This alert is still being written to". Any idea why they aren't being completed?

Comments

  • Anu DAnu D Posts: 876 Silver 3
    Thank you for your post and sorry that you are experiencing this issue.

    Is this problem occurring for all of the alerts or just this deadlock one?

    Can you please check the following setting in the server properties for each monitored server on your Production Alert Repository and if required modify the Execution time-out to set it to 0 seconds.

    Right click the computer in the Servers to show list and select Server Properties

    In the Server Properties dialog for each sever and confirm that the Execution time-out Connection setting is set to 0 seconds. If it is not set to 0 seconds, can you please modify it so it becomes 0 seconds and then stop and restart the SQL Response Alert Repository.

    Next monitor any new alerts and ensure that you are not getting the 'Alert is still being written to' in the alert details.
    Anuradha Deshpande
    Product Support
    Redgate Software Ltd.
    E-mail: [email protected]
  • I found an article about Excluding paths from the Anti-Virus Protection on the Server. The acticle said the Documents and Settings file path needed to be excluded, we weren't doing that, I had it added and it's working like a champ.

    :D
  • Anu DAnu D Posts: 876 Silver 3
    Many thanks for the confirmation.

    We are pleased that your issue is resolved.
    Anuradha Deshpande
    Product Support
    Redgate Software Ltd.
    E-mail: [email protected]
  • It's locked up again. Looks like it stopped trying to get the info for a deaklock. Is there any information in a log file somewhere? :x
  • Kindly can you confirm that you did the changes in my previous post:

    "Thank you for your post and sorry that you are experiencing this issue.

    Is this problem occurring for all of the alerts or just this deadlock one?

    Can you please check the following setting in the server properties for each monitored server on your Production Alert Repository and if required modify the Execution time-out to set it to 0 seconds.

    Right click the computer in the Servers to show list and select Server Properties

    In the Server Properties dialog for each sever and confirm that the Execution time-out Connection setting is set to 0 seconds. If it is not set to 0 seconds, can you please modify it so it becomes 0 seconds and then stop and restart the SQL Response Alert Repository.

    Next monitor any new alerts and ensure that you are not getting the 'Alert is still being written to' in the alert details."
    Anuradha Deshpande
    Product Support
    Redgate Software Ltd.
    E-mail: [email protected]
  • I forgot to mention how to obtain SQL Response log files.

    We have a knowledge base article for that : http://www.red-gate.com/supportcenter/C ... _files.htm
    Anuradha Deshpande
    Product Support
    Redgate Software Ltd.
    E-mail: [email protected]
Sign In or Register to comment.