Competition: What’s your favorite Redgate tool? Enter now.

SQL Backup 6 with DFS Share

wilsoncwilsonc Posts: 7
edited February 9, 2010 10:23AM in SQL Backup Previous Versions
Hey Guys,

We have been using SQL Backup 6 for the past couple months with great success. Today we tried pointing it to a dfs share and it fails while creating a backup. It only fails while writing to a dfs path. The path is accessible to the server correctly under the context of the user running the backup as a backup can be correctly performed using Enterprise Manager/Sql Studio from the same server.

Is there a known issue? If so, is there a work around for this?

Comments

  • backup from management studio will use the credentials of the SQL Server agent, backup from SQLBackup will use the SQLBackup servuice credentials. Have you checked permissions to ensure the sqlbackup service account has access

    do you get any error from SQLBackup at all?
  • we tried manually specifying different user credentials with the same result. The permissions on the share are the same directly or through dfs. I will post an error log when back in the office tomorrow.
  • This an error that was spit out when attempting to backup to the dfs path. When using the path directly, ie \\remoteserver\share with the same credentials it works correctly.

    These errors are generated for all databases the job encompasses.


    ERRORS AND WARNINGS


    1/18/2010 10:04:11 AM: Backing up master (full database) to:
    1/18/2010 10:04:11 AM: \\adms_nt\shares\SQLBackups\DIF\SERVERNAME\SYSTEM\FULL_master_20100118_100411.sqb

    1/18/2010 10:04:12 AM: BACKUP DATABASE [master] TO VIRTUAL_DEVICE = 'SQLBACKUP_A6C4AD78-EBC2-4BF4-98B5-88110589C550', VIRTUAL_DEVICE = 'SQLBACKUP_A6C4AD78-EBC2-4BF4-98B5-88110589C55001' WITH BUFFERCOUNT = 12, BLOCKSIZE = 65536, MAXTRANSFERSIZE = 1048576, NAME = N'Database (master), 1/18/2010 10:04:11 AM', DESCRIPTION = N'Backup on 1/18/2010 10:04:11 AM Server: SERVERNAME Database: master', FORMAT

    1/18/2010 10:04:18 AM: Thread 1 error: Backup error: Division by zero
    See error details in log file: C:\ProgramData\Red Gate\SQL Backup\Log\SQBCoreService_(LOCAL)_bugreport.txt
    1/18/2010 10:04:18 AM:
    1/18/2010 10:04:18 AM: SQL error 3013: SQL error 3013: BACKUP DATABASE is terminating abnormally.
    1/18/2010 10:04:18 AM: SQL error 3271: SQL error 3271: A nonrecoverable I/O error occurred on file "SQLBACKUP_A6C4AD78-EBC2-4BF4-98B5-88110589C55001:" 995(The I/O operation has been aborted because of either a thread exit or an application request.).
    1/18/2010 10:04:18 AM: Processed 376 pages for database 'master', file 'master' on file 1.
    1/18/2010 10:04:18 AM: Processed 3 pages for database 'master', file 'mastlog' on file 1.
  • In an attempt to handle this differently I created a DNS alias and pointed the server to the alias instead. I find that when running against an alias the job fails as well. It sits in a running state until it eventually times out.

    What check is occurring during this job that would prevent the job from running against an alias name? I am able to navigate to manipulate folders in the target path via the alias so it is able to see and connect to it.
Sign In or Register to comment.