What are the challenges you face when working across database platforms? Take the survey
Options

hourly backups are skipping days

PaulIPaulI Posts: 4
edited January 6, 2010 11:27AM in SQL Backup Previous Versions
hourly backups are skipping days they are set to run on.

I have a recurring backup set to run Weekly MON,tue,wed,thur,fri,sun, occurs every 1 hour, start time 8am end time 7:59am.

When the Sunday backups start Mondays get skipped, same when Tuesday starts Wednesday gets skipped an so on. I have no clue why and need some help fixing this.

Thanks
The Dude

Comments

  • Options
    Hi Paul,

    The backup jobs rely on the SQL Server Agent for scheduling. Is there anything to suggest that the jobs are starting then failing? The activity history will display failed attempts.

    If the jobs aren't even starting, I would examine the Agent's configuration from SQL Server Management Studio and the event log to see if it has posted any errors relating to this.

    Regards,
    Robin Anderson
    Development
    Red-Gate Software
  • Options
    In the job history there is nothng showing it fails. It just stops every other day at 7am and then starts back up at 8am the next day.

    I did find this on the day i created the backup, but i have no clue what that means.

    Message
    [162] Internal request (from SetJobNextRunDate [reason: schedule will not run again]) to deactivate schedule 14
    The Dude
  • Options
    I have seen similar problems with SQL Agent jobs that run from one day to the next.

    This is from my Connect item

    I tried to add a new schedule to an existing job. I wanted to run the job from 3.58pm to 4.00pm the next day. I set the Start and End date but when the time passed the Ending at time on the first day the job did not run. I changed the Ending at time to be less than the Starting time ie 3.50pm and the job runs.

    Looks like the scheduler is not looking at the End date when the Ending time is after the Starting time.

    We are on SQL2005 SP2 build 3282.

    I know that you are not quite like this but it is similar. I would change the start and end times to be in the same day.

    Chris
    English DBA living in CANADA
  • Options
    Problem was solved by setting the start time 00:00:00 and end time 23:00:00 from start 00:00:00 end 23:59:00.

    The job only takes 12 minutes to run but for some reason skiping 1 hour fixed the problem.
    The Dude
Sign In or Register to comment.