Why Would The Maintenance Window Not Work

EdCardenEdCarden Posts: 112 Bronze 3
edited November 1, 2013 6:04PM in SQL Monitor Previous Versions
WEB SERVER
Version: 3.3.0.270
Web Server: Mono.WebServer2/0.2.0.0
Server Name: http://SQL03:8080
Server HOST .NET: .NET 3.5 SP 1
Server Path: C:\Program Files\Red Gate\SQL Monitor 3\Web\WEBSITE
Hosted Environment: 64Bit
User: NT AUTHORITY\NETWORK SERVICE


BASE MONITOR
VERSION: 3.3.0.270
Base Monitor: SQL03.wamltd.com:7399
Install Location: C:\Program Files\Red Gate\SQL Monitor 3\BaseMonitor
Host Environment: 64Bit
User: NT AUTHORITY\SYSTEM

Domain: XXXXXX
Database: SQL03 *** RedGateMonitor



I have the Maintenance Window set for 10 minutes at 2AM daily. When the server being monitored rebooted this morning at 2:01AM SQL Monitor stopped monitoring at that time and I can tell this per the log file which has the error msg listed below.

1) If the maintenance window is from 2AM to 210AM daily then why would there be any probelm with a reboot that start at 2:091 AM and whcih is done and everything back up before the end of that maintenance window?

2) I have the "reconnectAfterAuthorizationError" value in the "RedGate.Response.Engine.Alerting.Base.Service.exe.settings" file set to true so why would the system stop trying to reconnect after the connection islost when the server being monitored rebooted?

I would think that between the maintenance window and the reconnectAfterAuthorization error being set to true SQL MOnitor would have no probelm with monitoring when a reboot occurs after the start of the maintenance window and is done before the end of the maintenace window and yet once the reboot happens montoring stops.

Thoughts?

LOG ERROR MSG: Monitoring stopped (Incorrect credentials or insufficient permissions)

Comments

  • Hello Ed,

    Sorry you're experiencing issues with the maintenance window.

    I was able to generate a similar problem by restarting my machine close to the end of the maintenance window -- perhaps it has something do with certain services not having enough time to start?

    Regarding the "reconnectAfterAuthorizationError" issue, would you be able to send your log files to us at [email protected]? There is a ticket open for you already (reference 6954). You can get the log files by going to configuration->about and clicking "retrieve all log files".

    Thanks,
    Evan
    Evan Moss
    Product Support
    (866) 627-8107
  • EdCardenEdCarden Posts: 112 Bronze 3
    Evan Moss wrote:
    Hello Ed,

    Sorry you're experiencing issues with the maintenance window.

    I was able to generate a similar problem by restarting my machine close to the end of the maintenance window -- perhaps it has something do with certain services not having enough time to start?

    Regarding the "reconnectAfterAuthorizationError" issue, would you be able to send your log files to us at [email protected]? There is a ticket open for you already (reference 6954). You can get the log files by going to configuration->about and clicking "retrieve all log files".

    Thanks,
    Evan


    Evan,

    When I go to Config-About there is no 'Retrieve all log fiels' anywhere on the page. I have a link for 'View Web Server log file' and one for 'View Base Monitor log file' but thats it. There is no additional menu items or buttons or anything else that could lead to 'All Log files'.

    PLease advise.
  • Sorry about that; I forgot you were on an older version of SQL Monitor. Can you just send in your most recent base monitor log file and website log file?

    Thanks,
    Evan
    Evan Moss
    Product Support
    (866) 627-8107
Sign In or Register to comment.