Cannot restore to local Windows8 - error 15404

PDinCAPDinCA Posts: 642 Silver 1
edited September 30, 2013 11:39AM in SQL Backup Previous Versions
SQL error 15404: Could not obtain information about Windows NT group/user 'MyCompany\me', error code 0x5.

I'm the only User who set up this machine and is successfully logged into the domain and is a local admin on the machine and has every server role (you can see I tried everything I could think of!). Even Adventureworks2102 didn't revolt when I attached it with log rebuild, so at least that part is good, and I can SELECT from its tables...

SQB Service WAS running under "Local Service" but I changed it to my domain login, despite enforced password changes every 90 days, just to poke that stick at it - no change.

I've restored this "Utility" DB across domains MANY times without incident.

I've been through the documentation site and tried to find and change everything, including the script to change to "sa" for the xp_...dll

What next, please?
Jesus Christ: Lunatic, liar or Lord?
Decide wisely...


  • peteypetey Posts: 2,358 New member
    After you've used the sqbsetlogin extended stored procedure to use a SQL login for the SQL Backup service, could you please check if the setting was saved in the registry, under ServiceLogin in
    HKLM\Software\Red Gate\SQL Backup\BackupSettingsGlobal\<instance name>
    and if the SQL Backup Agent service startup account has rights to read from that registry node?

    Alternatively, since there's only one user using that machine, you could set up SQL Backup to skip checking for backup and restore rights, by creating a SkipChecks DWORD registry value in the node above, and giving it a value of 1.
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
  • PDinCAPDinCA Posts: 642 Silver 1
    Took the alternative and I'm good to go. Many thanks Peter
    Jesus Christ: Lunatic, liar or Lord?
    Decide wisely...
Sign In or Register to comment.