Error in parsing

swapnilswapnil Posts: 2
We are facing issues with below error message -
Errors occurred whilst parsing file C:\Users\sshinde\AppData\Local\Red Gate\SQL Source Control 3\WorkingBases\qpum32p5.aiu\Stored Procedures\archive.DeleteArchivedLoad.sql
'' at line 26, column 29, near the text.

To resolve this issue :
1) Open affected file
2) Edit to insure SQL is correct
3) Commit the changes without using SQL source control. For example by using tortoise SVN or....

Please help me on how to resolve this issue.,,.


  • Is it always the same file that gives you the error message? Can you try unlinking and relinking the database, and see if it persists? If so, would it be possible for you to email us the affected file at [email protected], quoting the reference F0061365 in the subject line?
    Andy Campbell Smith

    Red Gate Technical Support Engineer
  • I realize this post is old but was there a fix to this problem? I can't fix the problem committing via TortoiseSVN. My error was

    There was an error parsing the file "C:UsersharmstAppDataLocalRed GateSQL Source Control 3Transientsw20mz4vo.1z3Stored Procedures<SPNAME>.sql" at line 5, column 7, near the text .
  • Got the same error. Any soluting to this? Also I can't send error reports. Gets stuck on Preparing the error report
  • conradakungaconradakunga Posts: 5 Bronze 1
    Getting this a lot more often of late.

    Trashing and recreating the repository is no longer workable as I get this error within 3 or 4 commits.
    Errors occurred whilst parsing file C:UsersRadAppDataLocalRed GateSQL Source Control 4WorkingBasesfie1sg2a.rsnStored ProceduresProcessInterestRollover.sql
    '' at line 123, column 569

    Needless to say the query in question is 100% valid.

    SQL Server 2014
    Git source control
    SQL Source 4.4.0
    Windows 10

    The report error tool also seems to hang indefinitely preparing the report
  • Errors occurred whilst parsing file C:\Users\{User}\AppData\Local\Red Gate\SQL Source Control 5\WorkingBases\coucolar.uwf\Stored Procedures\dbo.{Procedure Name}.sql

    '' at line 14, column 4

    '' at line 164, column 6

    '' at line 179, column 7

    '' at line 179, column 31

    '' at line 181, column 6

    This has started happening recently after upgrading to SQL Source Control Version I have a whole database which I can no longer use source control with. I checked the problem procedure was valid and it is. I then committed the procedure using Tortoise SVN, but it still doesn't work. I tried re-linking the database with source control as well, but nothing worked. I was going to attempt to downgrade to a slightly older version of SQL Source Control, but the newest version I could find online was Version 4.4!!! Can someone please tell me where I can find a later version (e.g. 5.8.3)? Or tell me how to fix this, but I assume it's a Red Gate bug.

  • NathanHobbsNathanHobbs Posts: 1 New member
    edited August 31, 2017 4:38PM
    I just got the same problem. I've checked the code and it's all valid. In my case the code appears to be the copy fetched from the server for comparison:
    Errors occurred whilst parsing file C:\Users\{UserName}\AppData\Local\Red Gate\SQL Source Control 5\Transients\v454ksvg.4cb\Stored Procedures\dbo.sp_sys_HouseKeeping_CacheDB.sql

    '' at line 16, column 7

    This is line 16:
    CREATE PROCEDURE [dbo].[sp_sys_HouseKeeping_CacheDB]
    Column 7 would be the space between CREATE and PROCEDURE!!!
  • CPickettCPickett Posts: 2 New member
    edited September 3, 2017 10:42PM
    +1 for this error on MS SQL 2014 + using Git as a repo - via a local folder.

  • CPickettCPickett Posts: 2 New member
    Updated to SQL Source Control 5.7 and now getting this as an error popup rather than just a notification on the Commit page.

    Errors occurred whilst parsing file c:\[username redacted]\AppData\Local\Red Gate\SQL Source Control 5\Transients\2u11zjj5.elq\Stored Procedures\[filename redacted].sql
  • I am also facing this error, Please let me know if there is a solution for it. I am using SQL Server 2017, SQL Source Control 5.1. It gives this error when I am connecting to a Working Folder using SQL Server 2014 SSMS and connecting 2017's Server on my local. Please help.  
  • Any resolution on this? I now am also facing this issue and its on the period between the dbo and procedure name!
  • I'm getting this too. Source Control 7.1.9.  I've even tried deleting the table and recreating it from a previous commit, which clearly was valid at the time.  No love.
  • Hi,

    This isn't a bug to reassure you and is often down to incorrect syntax in the files. 

    The solution on this can depend on whether the issue is with WorkingBases or Transients files.

    To investigate this further, I would advise reaching out to support at:

    Kind regards

    Dan Calver | Redgate Software
    Have you visited our Help Center?

  • I'm sorry, but I will have to disagree with you DanC.  I tried deleting the table in question, committing and relinking, only to have every table throw this error, even though there were no recent changes in these tables that were failing.  The solution via productsupport was to unlink,  delete my local repo, re-clone from remote and re-attach.  All was good, and no commits were shown.  It was not syntax.
Sign In or Register to comment.