No Database is available for the currently selected Range

I am vewing the message "No Database is available for the currently selected Range" after selecting Database calls section in the performance profiler after I am done with profiling. :x

Even I tried in the below manner but the result seems to be same:
1. selected Call tree view, and Wall-clock time on the results toolbar.
2. selected the portion of the timeline
3. Clicked on Database Calls.

In the call tree,I am not able to see any database Icon. Hence Eventhough I click on Database calls the result is same.

I have tried connecting to the database which is in my local development system and also to the databse which is in remote.

I have also browsed trough the logs, But I could not find any stuff related to database and the error. :?

Can u please ley me know
1)why I am not able to view SQL icon in the Call tree
2)Are there any special settings that have to be done before continuing with profiling
3) Any things to Cross check in scenerios like this.


  • dene.boultondene.boulton Posts: 42 Bronze 1
    Good Morning,

    From your description I am thinking you are using version 7.2, but can you please confirm this?

    What are type/versions of the databases you are trying to access?
    Dene Boulton
    Red Gate
  • Hi Dene:
    Here are the versions I am using::

    Red Gate: 7.2
    Sql Server : 2008 Version 10.0.1600.22
  • Hmm - thanks for the extra information, Chaitu.

    What profiling mode are you using? Sampling mode doesn't return any data on database calls - if you use another mode, you should see SQL call results.

    You also wouldn't see database call profiling results if you're using the Standard edition of ANTS Performance Profiler - SQL call profiling is available only in Pro edition.

    If you're using Pro and a non-sampling mode, can you tell us any more about the API your application uses to make SQL calls? It's possible it's one we aren't yet instrumenting.
  • Hi Dene, here are the required details::

    Profiling mode we are using: Line -Level and method Level Timings;all methods(most detailed)::::::


    our Application uses Microsoft API's (DAL) ,Enterprise libraries 4.0 to connect to the database..

    kindly let me know if any information is needed...
  • dene.boultondene.boulton Posts: 42 Bronze 1

    Would there be any chance that you would be able to send us a results file for a session that exhibits this behaviour? A simple test application would suffice - if you are unable to send results for one of your products.

    If so, you can send it to my email (buttons below).


    Dene Boulton
    Red Gate
Sign In or Register to comment.