What are the challenges you face when working across database platforms? Take the survey
Options

SQL Monitor cannot connect to cluster instance

JosephDMarshJosephDMarsh Posts: 3
edited November 21, 2011 10:21AM in SQL Monitor Previous Versions
I have installed SQL Monitor successfully (good so far). Got the repository db setup, the base monitor installed and running, the web site up and running, etc.

I have added one of my servers, and SQL Monitor is gathering-and-reporting data for that server as expected (still good).

I also added my cluster server, and SQL Monitor successfully gathered the list of nodes (there are 2), and is showing "(local)" for the default instance.

BUT, it won't connect to the cluster instance (there is only one, and it's the "default") ... To connect to my default instance, I have to specify a port, like this: "SQLCLUS1,61790". That's what I use for connect strings, as well as with SSMS. But when I attempted to use that, SQL Monitor tried to add two servers: one called "SQLCLUS1" and one called "61790".

I tried stipulating the port using "SQLCLUS1:61790", but the server name box just turns red and no useful error / help information is available.

I also tried stipulating the port via the "Connection Properties" popup, but that didn't work either.

- It's not a permissions issue (I tried to use the wrong credentials initially and got the "wrong credentials" error; the error I'm getting now just says "Unreachable | Cannot connect")

- It's not related to connectivity or the like (I was able to run the full list of suggestions from another post -- ping, perfmon, regedit, wemtest (?) -- without a problem)

SO, what am I missing? Please.
Thanks,
- Joseph Marsh

Comments

  • Options
    Hi Joseph,

    Could you try the following steps and let us know whether this works or not:

    1. Delete the old cluster registration and start afresh.

    2. Use this syntax for adding cluster: [name of any one cluster node]\* i.e. if your cluster has two nodes called as cluster1 and cluster2 then use cluster1\* for "SQL Server" name field.

    3. This should add all the nodes of the cluster and all the SQL Server instances running on this cluster.

    4. After SQL Server instances are listed then change the port number for the SQL Server instance using "Edit credentials" option.

    Thanks,
    Priya
    Priya Sinha
    Project Manager
    Red Gate Software
  • Options
    Priya,

    Success -- with one note.

    I removed the old cluster registration and added it as you suggested -- using a node name and the "\*".

    I had tried using the node name method previously, but not with the "\*".

    Both times, it found both nodes, but this time it was able to find the default instance without me having to do anything else (didn't have to edit the credentials).

    Working like a champ now. Thank you for your (excellent) help!
    Thanks,
    - Joseph Marsh
  • Options
    That's great news Joseph :). Glad that it is all working for you now.

    Regards,
    Priya
    Priya Sinha
    Project Manager
    Red Gate Software
Sign In or Register to comment.