Competition: What’s your favorite Redgate tool? Enter now.

SQL Compare Failure at Registering - Permission Error

dfellowdfellow Posts: 2
edited August 25, 2011 3:58PM in SQL Compare Previous Versions
I've started running into this problem since upgrading our development server to SQL2008R2. We are running Compare or Data Compare and receive the same error on both about permissions. It occurs at the "Registering databases - Reading permissions" step. The error message comes back as "The user does not have permissions to perform this action."

I ran a trace during the compare and find that the error occurs when trying to select from sys.dm_database_encryption_keys.

I see alot of complaints from Visual Studio users about this issue when trying to do a schema compare. It appears to affect Redgate in a similar manner.

Can anyone else confirm issues with this?

I see mention of "VIEW SERVER STATE" permissions requirement (http://www.red-gate.com/supportcenter/Content?p=SQL%20Compare&c=SQL_Compare%5cknowledgebase%5cSC_Permissions_Required.htm), but it says "to compare some encrypted objects." I have no encrytped objects in this database.

Thanks,
Donald

Comments

Sign In or Register to comment.