What are the challenges you face when working across database platforms? Take the survey
Options

problem with NoTransactions option?

vincentjvincentj Posts: 47
edited June 9, 2011 10:30AM in SQL Compare Previous Versions
I tried using /options:NoTransactions, and now my script includes a bunch of other objects that it shouldn't need for the sync. The script with transactions is 224KB, and the one with NoTransactions is 846KB. It should be smaller, right?

Is anyone else seeing the same issue? Am I doing something wrong?

Comments

  • Options
    James BJames B Posts: 1,124 Silver 4
    Thanks for your post. Interestingly, that's the opposite of what I'd expect.

    The extra objects are most likely appearing as they are dependencies of some other objects you were working with. If you check here you'll see that "IncludeDependencies" is one of the default options. By setting your option to just NoTransactions, that will disable ALL the default options.

    As I said, it's odd because i'd expect you to now have less objects than originally rather than more. In any case, can you try specifying the default options as well, and seeing how it affects things?, i.e.

    /Options:Default,NoTransactions
    Systems Software Engineer

    Redgate Software

  • Options
    Yes, specifying /options:Default,NoTransactions works perfectly!

    I guess I need to pay closer attention to the online docs, I'm sure I read that page at one point but apparently forgot all about it. Thanks for the help!
  • Options
    James BJames B Posts: 1,124 Silver 4
    No worries - glad it seems to be sorted!
    Systems Software Engineer

    Redgate Software

Sign In or Register to comment.