Strong name signing with a .pfx file fails

edited November 29, 2010 5:29AM in SmartAssembly 5
I've signed my assemblies with a strong name using a .pfx file. I have pointed my SA project to the pfx file and enabled the option to re-sign after obfuscation.

However, when I run the obfuscation build the process fails:

Creating Assembly...
ERROR: You have not entered the correct password for the key file.

I can't see anywhere in the SA project file or the UI to enter the password for my .pfx file.

How can I obfuscate if I've strong named using a .pfx file?


  • Try un-setting the pfx file option, then re-setting it. I think we have a bug where if you select a new pfx file, it tries to use the old password, you may have encountered that.

    There is a dialog to type the password that you should get.
    Red Gate .NET Tools
Sign In or Register to comment.