Licenses Mysteriously Deactivated

tlbroadbenttlbroadbent Posts: 25 Bronze 3
I opened the SQL Response client today and all SQL servers showed the message "trial period has expired." All of these servers had activated licenses. The Server menu showed showed both Activate Server License and Deactivate Server License in a disabled state. Likewise, right-clicking the each server showed the Licenses entries on the menu were disabled.

I uninstalled and the installed the Alert Repository. Now all SQL Servers indicate the activated license and the Deactivate menu selection is enabled. Is there a known reason why this might occur? Is there anything we can do to prevent this from occurring in the future?

I was out of the office and had not used SQL Response client for a few days. It appears that SQL Response Alert Repository stopped functioning sometime on Nov. 20. We have no alerts for nearly five days.

Additional information: At 9:15AM on Nov. 20, the server hosting the Alert Repository was rebooted. At 9:19AM SQL Response recorded an alert that the SQL Server computers were unrachable. There are no other alersts from that point until the Repository was reinstalled this morning.

Thank you for your assistance.
Terry L Broadbent
Database Administrator
L-3 Communications, Inc.


  • Hi
    Really sorry you've had this problem - I'm not sure what's happened... i've not hear of this before at least.

    Could you please answer the following first:
    - When you reinstalled did you have to reactivate or did the servers just come back as activated?
    - Did you try just restarting the alert repository service before reinstalling?

    Also if you could gather the logs from the Alert Repository machine (in documents and settings/all users/application data/red gate/logs/....) and then send them to [email protected] (and put a link to this forum post in so they know to send the files to me) that would be great - thanks.
  • Nigel,

    Thanks for your reply. I sent the logs in one ZIP file.

    I did not try to restart the Alert Repository before reinstallig.

    I did not have to activate licenses. They were activated when I connected to the repository.

    Terry L Broadbent
    Database Administrator
    L-3 Communications, Inc.
  • Thanks. I suspect that just restarting the service would have worked as well in that case - but obviously it shouldn't happen in the first place. I'll take a look at the logs and see what I can glean.
  • Ok - the logs came through. Because they were so big the ones for the time when it was rebooted had been deleted, however the ones that were left showed the problem.

    There's a bug in the Microsoft SQL connection stuff for which there is a fix on here Sadly it seems to be an on-request fix rather than a download, however they do say it would be in the next service pack (though if that is shipped yet I can't tell - The list of fixes for .NET 2.0 SP1 doesn't list this fix (

    It seems that once this error occurs it keeps recurring so the only way is to restart the repository and hope it doesn't happen again.

    However we'll try and make a case to reproduce it here and then hopefully we can try and put a workaround in to fix, or at least detect this happening and take action. I'll add it to our issue tracking system in the meantime.

    EDIT: So that people searching for this error the stack trace in the log that shows this is like
    06:26:00.616|Error  |AlertRepository     |28 |SqlServerUpMonitor : Failed to get information from SQL Server <servername> (code 0)|System.IndexOutOfRangeException: Index was outside the bounds of the array.
       at SNINativeMethodWrapper.SNIOpenEx(ConsumerInfo consumerInfo, String constring, IntPtr& pConn, Boolean fInitSec, Byte[] sspiBuffer, Byte[] instanceName, Boolean fOverrideCache, Boolean fSync)
       at System.Data.SqlClient.SNIHandle..ctor(ConsumerInfo myInfo, String serverName, Boolean integratedSecurity, Byte[] serverUserName, Boolean ignoreSniOpenTimeout, Int32 timeout, Byte[]& instanceName, Boolean flushCache, Boolean fSync)
       at System.Data.SqlClient.TdsParserStateObject.CreatePhysicalSNIHandle(String serverName, Boolean ignoreSniOpenTimeout, Int64 timerExpire, Byte[]& instanceName, Boolean integratedSecurity, Byte[] serverUserName, Boolean flushCache, Boolean async)
       at System.Data.SqlClient.TdsParser.Connect(ServerInfo serverInfo, SqlInternalConnectionTds connHandler, Boolean ignoreSniOpenTimeout, Int64 timerExpire, Boolean encrypt, Boolean trustServerCert, Boolean integratedSecurity, SqlConnection owningObject)
       at System.Data.SqlClient.SqlInternalConnectionTds.AttemptOneLogin(ServerInfo serverInfo, String newPassword, Boolean ignoreSniOpenTimeout, Int64 timerExpire, SqlConnection owningObject)
       at System.Data.SqlClient.SqlInternalConnectionTds.LoginNoFailover(String host, String newPassword, Boolean redirectedUserInstance, SqlConnection owningObject, SqlConnectionString connectionOptions, Int64 timerStart)
       at System.Data.SqlClient.SqlInternalConnectionTds.OpenLoginEnlist(SqlConnection owningObject, SqlConnectionString connectionOptions, String newPassword, Boolean redirectedUserInstance)
       at System.Data.SqlClient.SqlInternalConnectionTds..ctor(DbConnectionPoolIdentity identity, SqlConnectionString connectionOptions, Object providerInfo, String newPassword, SqlConnection owningObject, Boolean redirectedUserInstance)
       at System.Data.SqlClient.SqlConnectionFactory.CreateConnection(DbConnectionOptions options, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningConnection)
       at System.Data.ProviderBase.DbConnectionFactory.CreatePooledConnection(DbConnection owningConnection, DbConnectionPool pool, DbConnectionOptions options)
       at System.Data.ProviderBase.DbConnectionPool.CreateObject(DbConnection owningObject)
       at System.Data.ProviderBase.DbConnectionPool.UserCreateRequest(DbConnection owningObject)
       at System.Data.ProviderBase.DbConnectionPool.GetConnection(DbConnection owningObject)
       at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
       at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
       at System.Data.SqlClient.SqlConnection.Open()
       at g.a(String )
       at l.GetConnection()
       at aw.a(V )
       at az.a()
       at az.RunNow()
  • Nigel,

    Thanks for the update. I'll discuss installing the Hotfix with our team. In the meantime, if the problem occurs again, I will restart the Repository.
    Terry L Broadbent
    Database Administrator
    L-3 Communications, Inc.
  • Hi,

    we are using sql response 1.1. Have the same issues on this topic, this morning two servers with active licenses specifying that trial period expired. I have to restart alert repository service, and the problem fixed. Please let us know what would be the permanent fix. thanks
  • Nigel MorseNigel Morse Posts: 164 Bronze 2
    If you're seeing the same stack trace in the logs then the only fix available now is the hotfix from Microsoft that I mentioned in my last post here.
  • no, it is different, that's why i post it.
  • Nigel MorseNigel Morse Posts: 164 Bronze 2
    Ah - in which case it may be a different problem. Could you send the alert repository logs to [email protected] (and reference this thread in your email so they know to send it to me - thanks)
  • i just sent two log files, please let me know you got it. thanks
  • i tried to send two log files, but they are big, like 20M (not sure you could receive it), can you suggest another way (ftp) to get it?
  • Nigel MorseNigel Morse Posts: 164 Bronze 2
    If you email support they should be able to sort out an ftp transfer you.
  • Nigel MorseNigel Morse Posts: 164 Bronze 2
    Thanks - I have them now. The problem here is very different so I've passed the logs to the current response team who are investigating a similar issue to the one you seem to have.

  • I had this problem as well. Swore a bit, re-entered my serial numbers and all was back to normal. Fingers crossed it doesn't happen again.
  • I had this problem as well. Swore a bit, re-entered my serial numbers and all was back to normal. Fingers crossed it doesn't happen again.

    Exact same resolution here. Strange because prior to this happening I was at the limit of my license and when I re-entered it I received no errors. Maybe this re-activation doesn't look for valid license seats to be left?
Sign In or Register to comment.