Maximize the power of SQL Prompt with SQL Toolbelt Essentials. Watch now.

SQL Prompt 6 - Disabling History Tabs reload on startup

jedworkjedwork Posts: 3
edited April 8, 2014 9:44PM in SQL Prompt
I have an issue where I had severla 2008R2 SSMS sessions open, each with many SQL query windows.

My machine crashed and now when I try to start SSMS, the SQL Prompt tries to open all my previous sql windows, and then just crashed SSMS.

Is there a registry entry I can change to disable "Restore open tabs when SQL Server Management Studio starts" ?

If not, can I remove the backedup files myself?
SQLPrompt_6.2.0.241.exe and SSMS 10.50.1600.1

Ta

Comments

  • Aaron LAaron L Posts: 596 New member
    Hi jedwork,
    You can turn this off manually by setting OpenTabsOnStartup to false in "%localappdata%/Red Gate\SQL Prompt 6\ RedGate_SQLPrompt_CommonUI_Options_TabMagicOptions.xml"

    Roughly how many tabs were opening that caused the crash? I'm wondering if having an upper limit for the number of tabs sql prompt will try to open would avoid this in the future (or a confirmation if it's over a certain amount)

    Thanks,
    Aaron.
  • Ta, Ill try that.

    There were 179 historical files in my
    H:\My Documents\SQL Server Management Studio\Backup Files\Solution1
    directory of which 99 were non zero in size.

    Not sure how many of those SQL Prompt was trying to open however.
    This was a comedy of circumstances that lead to such a high number of files, so I don't expect this situation to arise again. Usually I only have about 20 or so open.

    An upper limit, or even a prompt window on opening, to allow the user highlight those files to open might be useful if a threshold is breached.
  • I was having pretty much the same issue, and changing the config value to false worked. SSMS was opening 40-50 windows, most of which were empty. I've never had that many windows open at a time.When SSMS didn't crash on startup Win7 would revert to the basic color scheme, and often at least one of the open windows in SSMS would have a large X, corner to corner.
  • UseruserUseruser Posts: 5 Bronze 1
    Old thread but I'm having this issue now in 2021. I tried uninstalling and re-installing SQL Prompt, removing 9 and upgrading to 10 in the process. I found that the setting is no longer in the xml file but related settings are now stored in the SavedTabs.db file in the folder previously mentioned which for me happens to be AppData\Local\Red Gate\SQL Prompt 10. I was able to open and edit the file using sqllitebrowser and set the relevant document to openstate 0, problem solved.
Sign In or Register to comment.