SQL Source Control slows downs SSMS

vjacob1vjacob1 New YorkPosts: 41 Bronze 1
Hi with the SQL Source Control Extension Installed - it severely slows down my SSMS in Object Explorer particularly when you right click the menu it takes forever.
Is anything being done to correct this issue?
Tried all the steps of taking out the polling and constant checking for new objects but it still is slow only if I uninstall the extension does it go back to normalcy.
I really like to have SQL Source Control so I can have source control on our database - can you please provide any solutions or potential updates for this?


Answers

  • Jessica RJessica R Posts: 1,319 Rose Gold 4

    Hi and thanks for your post!

    The slowness in Object Explorer is an unfortunate known issue in SQL Source Control and I'm afraid we don't have any ETA for the fix as it appears to be quite complicated from previous investigations.

    I know you mentioned you've tried all the options, but can we just double check that you've disabled object locking from the %localappdata%\Red Gate\SQL Source Control X\RedGate_SQLSourceControl_Engine_EngineOptions.xml file? 

    1. Close SSMS
    2. Open the file %localappdata%\Red Gate\SQL Source Control X\RedGate_SQLSourceControl_Engine_EngineOptions.xml in a text editor

    3. Add the tag to disable object locking as below:
      <?xml version="1.0" encoding="utf-8" standalone="yes"?>
      <!---->
      <EngineOptions version="3" type="EngineOptions">
      <EnableObjectLocking>False</EnableObjectLocking>
      </EngineOptions>
    4. Restart SSMS to test

    Disabling this can have the most impact in improving the slowness, so this is worth a check!

    If that's already disabled, I'm afraid there likely isn't much we can do at the moment.

    However, if you can please enable verbose logging, reproduce the slowness, zip up your logs in %localappdata%\Red Gate\logs, and send them to [email protected] with "Log files for #251931" as the subject, we can just double check if anything else may be contributing.

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • vjacob1vjacob1 New YorkPosts: 41 Bronze 1
    Hi Jessica,
    There is another thread on the forum shown in the hyperlink below
    I tried the suggestion of disabling the Redgate Client and the speed of SSMS increased
    However this also could be decreased load due to the holiday 
    I will try it tomorrow when normal office operations are back to see if the suggestion in this post fixes the issue.

    SQL Source Control slows down SSMS drastically — Redgate forums (red-gate.com)
  • vjacob1vjacob1 New YorkPosts: 41 Bronze 1
    I also updated to Source Control Version 7.2 and have the following options enabled and Object Explorer seems to be responding a lot faster


  • Jessica RJessica R Posts: 1,319 Rose Gold 4
    Thanks for the update! Just to confirm, did disabling the object locking help? Or has disabling the Redgate Client been the only suggestion that's had an effect?

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • vjacob1vjacob1 New YorkPosts: 41 Bronze 1
    @Jessica R - I do not really know - I did disable the Redgate Client but after re-enabling, it still has become faster.
    I did disable object locking but also turned off the polling so I guess it was a combination of these two that did it

    I did open a ticket with the Server and SQL DBAS to take a look at the actual SQL Server and perhaps they could have done something I do not know.
  • Jessica RJessica R Posts: 1,319 Rose Gold 4
    Ah interesting - I'm not sure either what improved it then, but I'm glad to hear it's faster nonetheless! 

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


Sign In or Register to comment.