Schema refresh list loop

BartmanDilawBartmanDilaw Posts: 11 New member
edited February 19, 2021 2:36PM in Schema Compare for Oracle
Context :
  • Oracle 19c standard
  • Schema Compare for Oracle - 5.7.13.906 (trial)
  • New project on Wizard with TNS Connection on source and cible.
  • Working home through VPN
I've filled and tested the source and cible credentials.
When I try to get schema list, I don't get any answer, the "Refresh list" starts a loop cursor, but never shows results...

I've tried with on local (Virtual Machine) Oracle instance. Wizard react the same.
I've tried to discard some consumating options (slow deps, dependent objects...).
Nothing is efficient.

[Edit]
I've found out that with the SYS as SYSDBA user, loop disappears...
The problem so stands while using an application USERNAME.
So, I think it's a GRANT problem.
The users have been created with CONNECT and RESOURCE grants...
[Edit End]

Any help should be appreciate.
Thanks.

Answers

  • Eddie DEddie D Posts: 1,699 Rose Gold 5
    Hi, thank you for your forum post.

    I suspect the problem you have reported is in regards to permissions and grants to various system objects and data dictionaries the comparison engine requires to perform the schema comparison.

    In the background, the comparison engine queries various system objects and data dictionaries, using the user account specified on the data sources tab or in the command line syntax.  By default, attempts to connect using the DBA_<object name> and if this fails switches to the ALL_<object name>.  The switch from DBA_ to ALL can take much longer than expected.

    This help document explains the permissions required for the comparison engine and the further information section lists all the data dictionaries and system objects that the comparison engine requires security permissions upon.

    Many Thanks
    Eddie
    Eddie Davis
    Product Support Engineer
    Redgate Software Ltd
    Email: [email protected]
Sign In or Register to comment.