How to connect to autonomous cloud database

rlogrlog Posts: 3 New member
edited January 12, 2021 8:19PM in Source Control for Oracle

I am trying to create a new Source Control project connecting to an autonomous database hosted in Oracle Cloud.  In order to connect to this database in (e.g. sql developer) I have to download the client credentials wallet and use that along with the tns entry.

I have tried a manual connection which results in a timeout, and have also tried adding the contents of the .zip wallet download from oracle into my local Oracle network\admin folder, and updating tnsnames.ora to add the connection string, but I still get a timeout.  Any tips?



  • Options
    rlogrlog Posts: 3 New member
    To add more info, when using TNS connection I have done the following:
    1. Checked 'OS/Wallet authentication'
    2. Added one of the three (low, medium, high) tns entries into tnsnames.ora from the client credentials download.
    3. Added the following two lines to my sqlnet.ora file
      WALLET_LOCATION = (SOURCE = (METHOD = file) (METHOD_DATA = (DIRECTORY="?/network/admin")))
    4. Copied cwallet.sso, ewallet, keystore.jks and truststore.jks into the /network/admin folder.
    When I run in Redgate Source Control I just get a timeout.

    Can anyone help?  This must be a fairly common situation.
  • Options
    Eddie DEddie D Posts: 1,782 Rose Gold 5
    Hi, thank you for your forum post.

    Sadly, I do not have any experience in configuring an Oracle Wallet.  You have found the option to enable and I understand that the wallet location needs to be entered into the sqlnet.ora file in the network\admin directory of your Oracle Client.

    A support ticket has been created for you.  I will send the setup instructions passed to me when support for the Oracle Wallet was first added to Redgate's Oracle tools back in April 2017 via this support ticket.  To my knowledge these instructions have not changed in the period since the above date.

    Many Thanks
    Eddie Davis
    Senior Product Support Engineer
    Redgate Software Ltd
    Email: support@red-gate.com
  • Options
    dprkrdprkr Posts: 1 New member
    Was/is there a resolution to this?  I am having the same problem connecting to autonomous cloud database.  I can connect from SQL developer and sqlcl (using tns) but not from Schema Compare 5
  • Options
    rlogrlog Posts: 3 New member
    I still have an open support ticket, hoping to get a resolution in the next few days.
  • Options
    I'd be grateful for a solution to this as well.
Sign In or Register to comment.